Hot water, but radiators not heating.



Hi all, I'm hoping you might be able to help...

I have a boiler/hot water tank central heating system, with a gloworm ultimate gas boiler and danfoss thermostat, and danfoss digital programmable control panel.

I Haven't used the radiator heating since winter last year, went to turn up the thermostat today, and noticed that none of the radiators are getting warm. The water is heating fine, and the boiler kicks in when the timer calls for the water to be heated, and goes off again when the water is all heated. If I turn up the thermostat up to max, and put the control panel on 'all day' nothing happens. The boiler just wont kick in when the heating system calls for it. I just don''t get it!?!

I've just checked in the airing cupboard and there's a danfoss box looking thing, with a metal lever from Auto and Man. It's set to Auto, and it's starts to make clicking noises when the heating it called for, but the boiler doesnt fire. When the water calls for heat, the boiler fires immediately, and the clicking noises start. One of the screw was really loose on this box thing, so I've tightened it, but that hasn't fixed it.

Has any one got any ideas, as it's really cold and my wooley jumpers are making me look like an extra from emmerdale farm!?

Cheers guys.

Sponsored Links
Before I go any further, it may be that your Room Stat is faulty.

However, the Actuator that gas4you is talking about drives a Motorised Valve and this valve controls the distribution of heated water from the boiler to the radiators and/or cylinder. Now, you could try flicking the manual override lever over to manual (open) and see if that works.

If it does then the Actuator is gooshed and needs replacing but the system is safe to use and will work in this manual position but it will be constantly open so if its a hot day (hot day... ha ha ha yeah right) your hot water AND heating will be on.

If it doesn't work then try taking off the actuator (looks like a box on top of the pipes). Underneath you will see a spindle sticking up. It will probably look like the bottom of a flat head screw driver sticking up. Get a pair of pliers and try turning it. It should be fairly easy to rotate. If its stiff then try moving it back and forth to try and free it up. Sometimes they get bits of grit in them and seize up a bit and giving them a bit of a turn with pliers can free them up again.

If it is already freely moving (and you are sure the Room Stat is not at fault) then I think the Actuator is a fairly good bet for replacement.

If it is stiff and you cannot free it up then the valve needs replacing as buying and fitting a new actuator won't solve the problem. The new actuator will struggle to move the valve spindle as much as you did with the pliers. However, if it was stiff and you managed to free it up then try replacing the actuator and see if it works (return the manual override lever to auto).

Just one last thing, before you go moving the motorised valve spindle... Mark with a pen/pencil which way the Spindle is facing so you can return it to its original position after you have tried to free it up.

Hope that helps.
Is it me? You come on here giving advice in your own time FOC... people could at least let us know what happend :rolleyes:
Sponsored Links
ok cheers for the help guys. It was the Danfoss actuator head. I've had it replaced (had the boiler serviced at the same time) and the heating works again! yay. I was always going to reply here, i just needed to wait until it had beed checked out., btw. I appreciate the advice guys, so I can sense check prices etc, if I don't fancy looking at it myself.

Slight issue though, Now whenever the hot water kicks in, the heating turns off (the boiler stops firing immediately). So if the heating is on permanent (and thermostat at say 30), then when the hot water kicks in (on timed/or manual) then the boiler stops firing straight away.

Im guessing the gas man, has wired the actuator incorrectly, he's coming back next week to have a look, but wondered if I was missing anything?

Cheers, River.

DIYnot Local

Staff member

If you need to find a tradesperson to get your job done, please try our local search below, or if you are doing it yourself you can find suppliers local to you.

Select the supplier or trade you require, enter your location to begin your search.

Are you a trade or supplier? You can create your listing free at DIYnot Local