1. Visiting from the US? Why not try DIYnot.US instead? Click here to continue to DIYnot.US.
    Dismiss Notice

Renault Trafic

Discussion in 'Car Repairs / Maintenance' started by spareshunter, 21 Aug 2018.

  1. spareshunter

    Joined:
    19 Jul 2008
    Messages:
    4,371
    Thanks Received:
    663
    Country:
    United Kingdom
    I have a Renault traffic CDI 100 2006 plate panel van. I cleaned the EGR valve and the MAF sensor has one of the sensor blades missing. Put all back together and now no start just turns over. I am at a loss, any help out there? Much appreciated.
     
  2. Peter.N.

    Joined:
    26 Sep 2006
    Messages:
    1,690
    Thanks Received:
    255
    Location:
    Dorset
    Country:
    United Kingdom
    A failed MAF doesn't prevent it from starting, at least not on PSA vehicles, so I suspect its something you have done while working on it. I suggest that you carefully check all the connections

    Peter
     
    • Thanks Thanks x 1
  3. spareshunter

    Joined:
    19 Jul 2008
    Messages:
    4,371
    Thanks Received:
    663
    Country:
    United Kingdom
    Thanks, Peter for the confirmation about the MAF valve. Yes, I will have a check again to see whats-whats, weird though.
     
  4. spareshunter

    Joined:
    19 Jul 2008
    Messages:
    4,371
    Thanks Received:
    663
    Country:
    United Kingdom
    All done, not got a clue what was wrong but took all electrical plugs off and reinstated checked all fuses, ok, and bobs your uncle. (y)
     
Loading...

Share This Page