Suprima kettling?

Joined
17 Mar 2020
Messages
36
Reaction score
1
Country
United Kingdom
Hi folks

I have a '98 Suprima 40 and hot water cylinder (3 port valve), after approx 5 mins from cold and selecting hot water I get kettling symptoms (some fizzing/mild clonks) from about 60c to 70s.

I have measured the temperature on the outlet with an infra red thermometer & the thermistor stat is kicking in at 70c. There is approx 6-7c difference on the inlet/outlet also measured near the outlet pipes.. Pump speed changing to 3 (grundfos) helps a little but the issue is still there. The main PCB has been changed in the past also.

I did try x200 last year but it made no real difference. Other than that the boiler works fine.

Any suggestions?
 
Sponsored Links
Joined
8 Sep 2005
Messages
2,062
Reaction score
450
Location
worlds end
Country
United Kingdom
Possibly restrict,try running a magnet around your heating pipes near the pump,if it sticks it has a restriction starting,
 
Joined
17 Mar 2020
Messages
36
Reaction score
1
Country
United Kingdom
Thanks for the reply, nothing obvious around those pipes at all. I should mention the 'coolant' is also clear when I added the X200.
 
Last edited:

DIYnot Local

Staff member

If you need to find a tradesperson to get your job done, please try our local search below, or if you are doing it yourself you can find suppliers local to you.

Select the supplier or trade you require, enter your location to begin your search.


Are you a trade or supplier? You can create your listing free at DIYnot Local

 
Sponsored Links
Top