Visonic Powermaster-30 with GSM-350 PG2 problem

6 Mar 2013
Reaction score
United Kingdom
After spending two evenings configuring, enrolling and mounting all the 10 door contacts, 2 PIR sensors, KP-160 keypad, keyfobs and external alarm everything worked as designed except the the system can't detect the GSM-350 PG2 module (with and without SIM card insalled)

I did a Diagnostic test (Installer Menu -> 07: Diagnostics -> GSM/GPRS) and the result returned the message "GSM not found".

I reported the problem to the dealer and I got a RMA replacement GSM-350 Module.

Now, after installing replacement GSM module, the Powermaster-30 still can't detect the GSM module. The Diagnostics still shows "GSM not found"

Yes, I took all precautions of disabling the mains and the battery pack power to the Control Panel before installing the GSM-350 module.

Is there something else I should be doing or is the Control Panel itself faulty?? Perhaps a jumper in the panel or I need a RS-232 module as well? I am at my wits end trying to figure out what can go wrong with such simple installation. I am trying to avoid Factory Reset and lose all the devices configuration.

I am also in contact with the dealer and if a solution is found, I will update this post.

Thanks in advance for your help.
Sponsored Links
Sorry you're having problems. My GSM module just plugged straight in (PowerMaster-10) and was recognised on next power up. ie, it just worked..
I suspect the main panel itself is faulty. It can't be that the replaced module is also not detected, unless I have received the GSM-350 for Powermax Pro and not the PG2 version.

GSM 350_V2 +Python
Model: GSM-350 ATS4
IC: 1467C-GE864

printed on the label on your GSM module?

In desperation, I've decided do to a Factory Default reset yesterday and re-enroll the sensors and reprogrammed the panel but still the diagnostics show "GSM not found"
Sponsored Links
Thanks cocjh1!

That looks exactly like mine and the part number is the same. I'm now really worried the central panel itself is faulty :(
Did you ever figure this out? I have the exact same problem.
Did you ever figure this out? I have the exact same problem.

First, I got a replacement GSM module. The new module didn't work either. After that, the vendor sent me a new control panel. I inserted the GSM module into it and it works well ever since.
So for my case, it was the control panel problem.
Okay - thanks - I appreciate your fast reply.

I will wait with any configuring before I talk to the electrician Monday. And maybe ask for a replacement modem or secondly a new main unit.


DIYnot Local

Staff member

If you need to find a tradesperson to get your job done, please try our local search below, or if you are doing it yourself you can find suppliers local to you.

Select the supplier or trade you require, enter your location to begin your search.

Are you a trade or supplier? You can create your listing free at DIYnot Local

Sponsored Links