Weird fan fault Vaillant EcoMax

DPJ

Joined
27 Oct 2017
Messages
14
Reaction score
1
Country
United Kingdom
Hi, thanks for looking... all advice / thoughts gratefully received!

Have an old Vaillant EcoMax 286 boiler that has had a strange intermittent fault over the past month.

About a month ago, it wasn't firing up and after a reset, came up with error F30 which is 'lack of air flow through appliance'. Did the diagnostics on it and it said fan speed should be 300, but was 170. Then, while in the fan speed screen, it changed from 300 to 220 (instructions say required speed and actual speed need to be within 20 of each other), and fired up. It kept failing over the next day or so and we were about to call for help, when I tapped the control panel and it all suddenly started working!

Subsequently it's been fine until tonight (5 weeks later) when it did the same thing. Again, fan speed too low to start. I tapped the panel in the same place and it started working again and has been fine since.

Basically, we know it's probably on its last legs, but is this something that anyone's had experience of? Do we need to get it sorted ASAP or is it likely to be a slow death over the next couple of months, which would make replacing it infinitely easier as we'd hopefully be out of lockdown?

Any thoughts?

Thanks!
 
Sponsored Links
Joined
28 Oct 2005
Messages
13,664
Reaction score
3,275
Location
Daventry
Country
United Kingdom
Could be a dry joint on the PCB. New PCBs are readily available, and the EcoMax is a decent boiler. I wouldn't be in a huge rush to change it.
 
  • Thanks
Reactions: DPJ

DIYnot Local

Staff member

If you need to find a tradesperson to get your job done, please try our local search below, or if you are doing it yourself you can find suppliers local to you.

Select the supplier or trade you require, enter your location to begin your search.


Are you a trade or supplier? You can create your listing free at DIYnot Local

 
Sponsored Links
Top