Worcester-Bosch Wireless Digistat Problem

18 Feb 2009
Reaction score
United Kingdom

I've searched the forum already and found that someone has had the same issue as me but there wasn't any conclusion so rather than me explain it all again this is the link to the previous guy's message:


The forum rules ask for the following info:

1) Boiler make / model (gas or oil)
Worcester/28i junior Gas Combi Boiler

2) What is / is not happening.
The wireless Digistat is not starting the heating (see further info below)

3) Has ANYTHING else been done or changed recently.
Just changed batteries in Digistat Transmitter

4) When did the problem start?
After changed batteries - wouldn't re-initiase rf connection

5) When does it happen? eg, heating coming on or going off.
Doesn't come on

6) Anything else you feel may be of relevance.
So, I changed the batteries of the Worcester Digistat Transmitter (to the letter of the instructions), then tried to re-initialise the rf connection by pressing the receiver buttons 1&2. Saw the correct quick flash of the red LED but then it goes solid red permanently an the Digistat Flame symbol coming on doesn't fire up the boiler

The forums I've read so far all seem to point to a faulty Receiver, I just don't understand why it would fail from simply losing it's signal when I changed the batteries in the Transmitter.

Are there any checks I can do on the PCB of the Receiver to see if it has indeed developed a fault (I'm from a technical background with electronics experience) no good without drawings or known voltages at key test points.

It still fires up the boiler when I press Overide.

Have got pics of Transmitter and Receiver in situ if that helps?

Any help gratefully received.
ps Sorry for long post.
Sponsored Links
Did you wait for the flashing lights to stop on the receiver before you re- installed the batteries?
Did you wait for the flashing lights to stop on the receiver before you re- installed the batteries?

Seriously, I could kiss you! Mate I don't know how I didn't try that before but it just worked - you've saved me £200 and a whole lot of grief off the missus for wasting money!

I shut it all down took the batteries out, fired it up, pressed/held button 1, pressed button 2 - quick Red LED flash then went out for the first time.
Put the batteries in and hey presto. Boiler fired!

Great job, thanks for the help!

DIYnot Local

Staff member

If you need to find a tradesperson to get your job done, please try our local search below, or if you are doing it yourself you can find suppliers local to you.

Select the supplier or trade you require, enter your location to begin your search.

Are you a trade or supplier? You can create your listing free at DIYnot Local

Sponsored Links