1. Visiting from the US? Why not try DIYnot.US instead? Click here to continue to DIYnot.US.
    Dismiss Notice

2003 Vauxhall corsa 1.2 petrol won't go above 30mph

Discussion in 'Car Repairs / Maintenance' started by littlecookie, 26 May 2015.

  1. littlecookie

    littlecookie

    Joined:
    22 Apr 2005
    Messages:
    240
    Thanks Received:
    0
    Location:
    Yorkshire
    Country:
    United Kingdom
    Hi my sons 2003 corsa 1.2 petrol feels like it's running on 3 cylinders no power at all ,changed coil pack but still same new plugs too up hill is about 15mph on flat lucky if it gets up to 30mph,feels a bit splutterry too when excererating ,it's quite high mileage at but up til now been running ok ,engine warning light showing on dash too
     
  2. Sponsored Links
  3. gregers

    gregers

    Joined:
    28 Mar 2008
    Messages:
    6,301
    Thanks Received:
    500
    Location:
    Sussex
    Country:
    United Kingdom
    then i would say its gone into limp mode.

    get the codes read either by buying a obd lead,download some software for your car and using a lappy read the fault codes on your ecu.

    or spend a fortune at the dealers.

    but the codes will need clearing.
     
    • Thanks Thanks x 1
  4. littlecookie

    littlecookie

    Joined:
    22 Apr 2005
    Messages:
    240
    Thanks Received:
    0
    Location:
    Yorkshire
    Country:
    United Kingdom
    Ok cheers never heard of limp mode until.now, Is there anything you can think of to check before, I take it to local garage, someone says egr valve might be clogged, not a clue myself
     
  5. Belle427

    Belle427

    Joined:
    16 Jan 2006
    Messages:
    2,980
    Thanks Received:
    289
    Location:
    Newport, S Wales.
    Country:
    United Kingdom
    The maf sensors fail commonly on these and cause that kind of issue, you can disconnect it and generally the car should run better which proves its cream crackered.
    Its located on or near the main black plastic air filter housing, if you need help locating it post up a picture of the engine bay.
     
    • Thanks Thanks x 1
  6. mfarrow

    mfarrow

    Joined:
    2 Nov 2009
    Messages:
    2,126
    Thanks Received:
    244
    Location:
    Warwickshire
    Country:
    United Kingdom
    Does it free Rev OK when hot up to the red line? If not could be blocked exhaust. Drop down pipe and see if it runs better.

    Also check breather pipes around the valve cover and manifold. Are they all still in good condition and attached?

    What was the condition of the plugs when you changed them?
     
    • Thanks Thanks x 1
  7. littlecookie

    littlecookie

    Joined:
    22 Apr 2005
    Messages:
    240
    Thanks Received:
    0
    Location:
    Yorkshire
    Country:
    United Kingdom
    will check pipes, plugs where bad, one was a bit blacker than rest
     
  8. Sponsored Links
  9. littlecookie

    littlecookie

    Joined:
    22 Apr 2005
    Messages:
    240
    Thanks Received:
    0
    Location:
    Yorkshire
    Country:
    United Kingdom
    Looks like engine screwed ,gunked up rattling now really bad ,cheers for help.
     
  10. mfarrow

    mfarrow

    Joined:
    2 Nov 2009
    Messages:
    2,126
    Thanks Received:
    244
    Location:
    Warwickshire
    Country:
    United Kingdom
    These engines are a bit of a pig. The chains tend to go slack and they end up sounding like a diesel when hot.

    Mother in laws had an oil pressure issue where the pressure relief valve piston had started sticking in its bore. So low oil pressure isn't an impossibility, but it doesn't immediately explain the lack of power.
     
  11. littlecookie

    littlecookie

    Joined:
    22 Apr 2005
    Messages:
    240
    Thanks Received:
    0
    Location:
    Yorkshire
    Country:
    United Kingdom
    Much louder than diesel ,taken it to a garage to sort out ,engine is worn out ,has lasted over 100000 though
     
  12. mfarrow

    mfarrow

    Joined:
    2 Nov 2009
    Messages:
    2,126
    Thanks Received:
    244
    Location:
    Warwickshire
    Country:
    United Kingdom
    Replace it with a 1.7dti/di diesel, wife's is on 176k now.

    :)
     
    • Thanks Thanks x 1
  13. rds60h

    rds60h

    Joined:
    5 Mar 2015
    Messages:
    28
    Thanks Received:
    3
    Location:
    Bedfordshire
    Country:
    United Kingdom
    This problem is usually the Coil Pack, the EGR Valve (Exhaust Gas Recirculation) especially on the Twinport engines, the ECT Sensor (Engine Coolant Temperature) or the MAF Sensors (Mass Air Flow).
    Unfortunately all 4 of these can throw up similar fault codes and usually means having to illuminated the ones that are OK.
    Two other possibilities but rarer are a cracked exhaust manifold or the collapse of the inside of the catalytic convertor.

    **My Mk5 Astra 1.6 has just started the exact same symptoms !
     
  14. rds60h

    rds60h

    Joined:
    5 Mar 2015
    Messages:
    28
    Thanks Received:
    3
    Location:
    Bedfordshire
    Country:
    United Kingdom
    Changed my Coil Pack this afternoon, Bingo !!
    It's running sweet as a nut.
     
Loading...

Share This Page