Audi A5 Coupe 2015 2.0 Diesel

Joined
8 Nov 2006
Messages
319
Reaction score
9
Location
London
Country
United Kingdom
Dear All

I have an Audi A5 2015 2.0 Diesel. It has gone into limp mode and Ross Tech Vag Comm gives the following error:-

019225 Boost Pressure Regulation.

The Car been to a Garage as it bought from a Dealer. The Garage say they replaced Turbo and cleaned DPF.

Upon driving it the same problem has appeared! Please see attached diagnostic photos. Anybody have any idea what the real issue maybe?

Many Thanks All.

Caesar ( Should have stuck to the Chariot, little fuel costs and No congestion charge!!)
 

Attachments

  • PHOTO-2021-08-25-18-30-37-2.jpg
    PHOTO-2021-08-25-18-30-37-2.jpg
    122.3 KB · Views: 60
  • PHOTO-2021-08-25-18-30-37.jpg
    PHOTO-2021-08-25-18-30-37.jpg
    121.8 KB · Views: 59
Sponsored Links
Joined
1 Sep 2018
Messages
446
Reaction score
72
Country
United Kingdom
As you have VCDS can you run a live log (While a 2nd person drives the car) choose "boost requested" and "boost actual" among the criteria to log. If the turbo has been replaced but is failing to boost this will show how much by. It is possible that the garage may not have changed the turbo actuator and it is also possible that they may not have cleaned debris from the intercooler if it was a physical turbo failure.
Other areas to check are boost hoses collapsing (delaminated inside), boost leaks and also make sure the EGR valve and the anti-shudder valve are not clogged with soot and operating correctly.
 
Joined
7 Feb 2008
Messages
23,642
Reaction score
4,701
Location
Northumberland
Country
United Kingdom
Was the replacement turbo a new one, or just a replacement?
I’d go for the large diameter air pipes from the intercooler to the turbo being adrift.....you can feel the boost pressure when you squeeze them.
Also look for the small air pipe going to the turbo actuator coming adrift or split.
John :)
 
Joined
8 Nov 2006
Messages
319
Reaction score
9
Location
London
Country
United Kingdom
Hi All

Many thanks for the solutions, will take a look and let you know the outcome.

Regards

Caesar
 
Joined
8 Nov 2006
Messages
319
Reaction score
9
Location
London
Country
United Kingdom
Hi All

Things get even stranger! Now have the following codes appears!!
P029900 Turbo / Super Charger Underboost

P208E00 Reductant Injection Valve stuck Close Bank 1 Unit 1

What are these codes now indicating?
 
Sponsored Links
Joined
1 Sep 2018
Messages
446
Reaction score
72
Country
United Kingdom
I think the adblue valve is stuck. The car doesn't need to go into limp mode for it's own health but EU regs stipulate that it must. Adblue equipment is subject to failure from crystallizing especially if a car is laid up for a while. It is quite common for people to get an ecu specialist to "delete" the adblue part of the software from the cars ecu.
 
Joined
1 Sep 2018
Messages
446
Reaction score
72
Country
United Kingdom
I would try filling the adblue first though, 615 miles range means there really may only be a splash in it!
 
Joined
12 Jan 2014
Messages
4,322
Reaction score
623
Location
Essex
Country
United Kingdom
sounds like the dpf is getting blocked quickly as its not regenerating effectively.

it's surprisingly common and causes all sorts of issues.

a lot of the time just cleaning the dpf fails to fix the problem and a new dpf is required.

in your case the injection valve appears to have failed, again quite common.

on the pool car at work we ended up having it all deleted and the ecu remapped to stop it occuring, we repalced everything and spent thousands on it, with no real fix.

since deletion its been tickety boo.
 
Joined
8 Nov 2006
Messages
319
Reaction score
9
Location
London
Country
United Kingdom
Hi Folks

Just a quick update the AdBlue injector was replaced and AdBlue topped up to full BUT the dash Light still stays on!!! Car still says that it only has 250 Miles before Adblue runs out! Heard car will not restart once Adblue runs out??
Audi Specialist who did the work says that the light can only be reset by Audi! Does anyone know how to reset this light without having to go to Audi???
The only error code coming up on VCDS is 00003 control module. No other error codes have come up, the audi specialist has shown the rest of the codes showing the car itself has registered the work and the full amble but states the 00003 control module code for basic setup is just for the adblue warning light.
any help will be greatly appreciated.

Many Thanks

Caesar
 
Joined
1 Sep 2018
Messages
446
Reaction score
72
Country
United Kingdom
Hi Folks

Just a quick update the AdBlue injector was replaced and AdBlue topped up to full BUT the dash Light still stays on!!! Car still says that it only has 250 Miles before Adblue runs out! Heard car will not restart once Adblue runs out??
Audi Specialist who did the work says that the light can only be reset by Audi! Does anyone know how to reset this light without having to go to Audi???
The only error code coming up on VCDS is 00003 control module. No other error codes have come up, the audi specialist has shown the rest of the codes showing the car itself has registered the work and the full amble but states the 00003 control module code for basic setup is just for the adblue warning light.
any help will be greatly appreciated.

Many Thanks

Caesar
A lot of more recent cars can actually detect their own Adblue level and as such "reset" themselves, however, the earlier Adblue cars had no facility to check their own levels and did indeed require a reset via OBD. It is quite possible/probable that your car will require a reset before it "knows" it has Adblue in the tank.
 
Joined
8 Nov 2006
Messages
319
Reaction score
9
Location
London
Country
United Kingdom
Hi All

Many thanks for the reply. Tried resetting with VCDS no joy! It reports a fault with the control module and looks like the instrument cluster will indeed need to be reprogrammed by Audi! Not sure what the cost of this will be, been advised it may take hours to do and Audi will apply their hourly rate!!
 
Sponsored Links
Top