Baxi solo 2 40pf burner keeps cutting out

Discussion in 'Plumbing and Central Heating' started by Anil777, 27 Mar 2014.

  1. Anil777

    Anil777

    Joined:
    29 Dec 2013
    Messages:
    9
    Thanks Received:
    0
    Location:
    London
    Country:
    United Kingdom
    Hi all.

    My parents baxi solo 2 boiler keeps cutting out. The fan runs and the pilot light lights up. Then the burner kicks in for 2-3 seconds then cuts out. Was working fine couple weeks ago but they came back from holiday yesterday and it never fired back up properly. The pump seems fine.
    I dunno what it could be, I recently posted a problem regarding my boiler on this website and found a result. So I thought I'd try my luck again.
    Could someone please help and thanks in advance.
     
    • Like Like x 1
  2. Sponsored Links
  3. bazdaman

    bazdaman

    Joined:
    2 Feb 2010
    Messages:
    1,382
    Thanks Received:
    317
    Location:
    Lancashire
    Country:
    United Kingdom
    RGI time im afraid not a diy fix.
     
  4. neiltheplumber

    neiltheplumber

    Joined:
    13 Feb 2011
    Messages:
    668
    Thanks Received:
    108
    Location:
    Birmingham
    Country:
    United Kingdom
    Could be the fan Venturi, ntc, or gas valve. No point guessing though so get an engineer in and let him find the fault.
     
  5. AngelesPlumbing

    AngelesPlumbing

    Joined:
    27 Mar 2014
    Messages:
    627
    Thanks Received:
    157
    Location:
    London
    Country:
    United Kingdom
    Check on the on flue might be blocking the airway or call gas safe engineer to check if combustion burning correctly.
     
  6. Sponsored Links
  7. Anil777

    Anil777

    Joined:
    29 Dec 2013
    Messages:
    9
    Thanks Received:
    0
    Location:
    London
    Country:
    United Kingdom
    Thanks guys for the quick response. I called out and engineer today and he said could be the temp sensor so he checked it with his multi meter and he getting a reading from it so that's ok. He's ordered a new gas valve said its going to come tomorrow or on Monday :( . Though he didn't sound to sure himself if it was the gas valve causing the problem. I asked him about the fan &flue and he goes that's all clear. Gonna cost me over £200 :(
    Hopefully it works though
     
  8. Agile

    Agile

    Joined:
    26 Jun 2004
    Messages:
    64,039
    Thanks Received:
    4,595
    Location:
    London
    Country:
    United Kingdom
    He sounds like a guesser to me!

    Dont pay for parts which dont fix the problem!

    Tony
     
    • Like Like x 1
  9. Anil777

    Anil777

    Joined:
    29 Dec 2013
    Messages:
    9
    Thanks Received:
    0
    Location:
    London
    Country:
    United Kingdom
    I just checked the temp sensor and I don't get a resistance reading from it. Is that right? Just doesnt show anything.
    He tested it yersterdsy and said it was fine 😕
     
  10. Agile

    Agile

    Joined:
    26 Jun 2004
    Messages:
    64,039
    Thanks Received:
    4,595
    Location:
    London
    Country:
    United Kingdom
    In this respect your RGI was correct.

    Most boiler sensors are 10 k !

    But the Solo is 1 Meg !

    Measure again on the correct range.

    Tony
     
  11. DIYnot Local

    DIYnot Local

    Joined:
    3 Sep 2019
    Country:
    United Kingdom

    If you need to find a tradesperson to get your job done, please try our local search below, or if you are doing it yourself you can find suppliers local to you.

    Select the supplier or trade you require, enter your location to begin your search.


    Are you a trade or supplier? You can create your listing free at DIYnot Local

     
Loading...

Share This Page