Desperate!!!! Valiant Combi Turbo Max pressure low and leak!

22 Oct 2005
Reaction score
United Kingdom

I just need to know how to bring the pressure up from 0 to 1.5.

I have located the filing loop and one of the screws on it.

I am told I need to open another screw until the pressure goes up.

Please could you tell me where this is?

Sponsored Links
On the other end of the filing loop usually.
Theres been a few different types of filling loop so I can only give general guidance unless you post a picture
Chances are there was a lever similar to that on a washing machine valve and this lever has fallen off leaving something like a circular shaft with two opposing flat sides where the lever slotted onto it.
General rule for valves and such is that if the lever / screw slot is in line with the pipe its turned on and if it's across the line of the pipe its turned off.
Basically all you need to do is open both valves [if it has 2 valves] until the guage reads anything between 1 - 1.5 bar.
Best to get that leak fixed soon though, as every time you add water to the system you are increasing the amount of corrosion going on within it.
Hi Slugbaby,

Thanks very much for your help.

I have found the two screws. You were right about the valve on the brass component. I have opened both. The pressure gauge is not changing and I can't hear any flow of water through the filling loop.

I have tried with the boiler on and off but nothing appears to happen.

What else am I missing?
The filling loop is integral to the boiler and it isn't glaringly obvious what's open and what's closed. Maybe with them both closed the water goes through ;) ?!!
Sponsored Links
I have tried a combination of ways bu the water is not flowing.
Do I need to do anything else to trigger a flow?
I now have the display with a red light lit saying "F.28"
Must be some water pressure in the boiler or you'd get a low water error.

Boiler goes to lock out No gas; Insufficient gas; Incorrect gas valve
adjustment; Electrode defective; Ignition lead defect;
Electronic igniter defective

Have you turned the gas off - 16mm square thing?

I had F.28 displayed. My manual says it means I need to fire up the boiler again. I have tried doing this but since using the depressurising valve knob, (the big grey one) I have lost so much water in the tank that it refuses to ignite again.

I still have not guessed how to refil it.

Can somebody give me a step by step run through of what I need to do to get water pumped back into the tank and how long it takes for the pressure gauge to go from 0 to 1.5. Thanks.

My number is 07960193404 and I am happy to call back.


-----to think I was considering a self build project!!!----
I have fixed the pressure and the leak using just your help. I am very grateful to all who chipped in.

I hope you all do well in whatever business you are involved in.

As I am just starting of as a lawyer, I would be happy to exchange tipsof the trade one day.

All the best and thanks

What stage have you reached with the law and which aspect?

I cannot ask if you are practicing because If I said I wanted to practice fixing boilers people would steer clear of me!


DIYnot Local

Staff member

If you need to find a tradesperson to get your job done, please try our local search below, or if you are doing it yourself you can find suppliers local to you.

Select the supplier or trade you require, enter your location to begin your search.

Are you a trade or supplier? You can create your listing free at DIYnot Local

Sponsored Links