Drayton Digistat RF1 & SCR

18 Mar 2007
Reaction score
United Kingdom
I have an RF1 & SCR and the SCR constantly shows a red light, so i thought it might be the RF1 Thermostat as it says the warranty expired 05/04 on the back of it so i thought it had died, replaced with a new RF1 tried to get the SCR to handshake with RF1 as follows:

Turn all power off to SCR & remove batterys from RF1

Turn power on to SCR and then hold down button 1 and then button 2 together - red light goes out - still holding down these buttons push the batterys back into RF1 unit

Now if i understand it should now perform the handshake and match the two units up together but i still get the red light on the SCR !

Any one have any ideas what i have done wrong or is my SCR dead !!!

If it helps it was working all OK till about 1 week and the boiler is new fitted about 1 year ago i think - My new RF1 only has one battery draw as well.

Many Thanks
Sponsored Links
to enter learn mode push the button marked 1 followed by 2 and hold both depressed together.The red led should flash for 2 seconds then go out signifying the scr is in learn mode. RELEASE BOTH BUTTONS.
The red and green leds should both now be on.
Take the digistat rf and hold it in sight of the scr no closer than a meter.
slide down right battery draw (are you sure you only have 1) remove the plastic strip and slide back into place.Repeat the same procedure with the left.

give it a try but dont forget to RELEASE BOTH BUTTONS before battery operation.

Take the RF1 unit up to the SCR.

Remove batteries and wait until display disappears completley. Check batteries are good. set scr into discovery mode. Push batteries back in as M I's, I think it is left pair first then right pair. You do not have to hold buttons on scr to lock together. They should now lock themselves together automatically. Follow M I's thoroughly. If all this fails replace unit ;)
One more point
check you have got a new RF1 and not a digistat 1

the digistat 1 has 2 AA 1.5 batterys

the rfi has 4 AA 1.5 batterys

Sponsored Links
All the ones I've fitted have been called the Digistat 1 and have 4 'AA' batteries 2 in each battery draw :confused:
I agree with you, all the i fit are the same .
but if the op has dashed down to b&q and picked up a digistat 1 in a hurry he has got the wrong one, hence the 1 draw

the digista 1 is hard wired only
Thanks guys making some progress now, yes your right dashed down B & Q and have brought the hard wired version which has one draw in it. So went back upto the scr unit and turned it off again. Then turned it on and held down one and then two the red led flashed very quickly for about 1 second and disappears, they green & red LED are both out. I release the two buttons and the red one comes on striaght away, the green one does not ?

Any other ideas
I think you have now missed the point! Hard wired version will not work at all with SCR. You MUST change it for the RF unit with 2 battery draws!

Red light on SCR means it is not receiving signal :rolleyes:
Hi, yep see what your saying about the hard wired version have taken it back and got my money back already.

When you hold buttons one & two when you release it the red & green leds should be lit up to show it is ready for the handshake from the RF1 unit. When i do this i only get the red light to come on.

Do the scr have a battery backup on board that may have failed ?

Not that I know of.

When replacing your RF unit I think you will find that you can only purchase the complete package. If you could find the RF unit seperatly I wouldn't mind betting it would be priced unreasonably :rolleyes:
Thanks for your help, been looking around on the net and found them at about £90 mark for transmitter and recieve so looks like a new one !!

many thanks for your help
use my e-mail link and I can tell you where they are £80 +VAT plus postage ;)
Had the same problem, and found one of the batteries had leaked and had made the connection in the right tray dirty. Cleaned the metal connection in the tray, changed the battery, and it got it to handshake with the receiver! I will be taking back the other other rf1 one i had bought ready to replace it.
Turn the power off at the mains then back on and you will have a red light on the receiver. Push button 2 and then 1 simultaineously. The red light will blink several times for about 2 secs. If it doesn't the receiver is shot. If it does push the right hand battery tray on the transmitter first then the left...no blinking, transmitter fault, if it blinks it works.............usually!!

DIYnot Local

Staff member

If you need to find a tradesperson to get your job done, please try our local search below, or if you are doing it yourself you can find suppliers local to you.

Select the supplier or trade you require, enter your location to begin your search.

Are you a trade or supplier? You can create your listing free at DIYnot Local

Sponsored Links