epson printer thinks its german lol

12 Jan 2009
Reaction score
United Kingdom
Can anyone help me i bought a epson stylus dx5000 printer about a year abo then i got a bad virus on my computer and had to wipe the lot....... but for some reason since i reloaded my printer into the computer it thinks its german and i cant understand it and the key boards messed up now too........ some off the buttons are in the wrong place............
Any advice would be appreciated but im not a computer geniuss so english please lol x
Sponsored Links
If Z and Y keys are swapped round then it has gone German. To set the keyboard back to normal, (Assuming windows XP), have a look in control panel, open up regional settings and select the Languages tab then click Details. If the default input language is not English try to change it but if English does not show as an option in the drop down list then you will need to add it in the part below. Also check all the other tabs in the regional settings and make sure everything is set to English (UK) and this might sort your printer out.

Auf Wiedersehen :LOL:
Its more that i don't have a pound sign or most off the special symbols that you get with shift, and the @ key is shift and the number 2 and shift and the @ key is " what the 2 should be!!!!!!!!!!!!!!!! any ideas????????
Have you checked in control panel as mike suggested?

The following should be standard for UK keyboard
@ = Shift and @ key
" = Shift and 2 (No. 2) key
£ = Shift and £ (No. 3) key

In Regional Options tab select English (united Kingdom)

Select Customise button then Currency tab and make sure currency symbol correct

Select Languages tab then click on Details and make sure your Default input language set to United Kingdom
Sponsored Links
Hello again, Did you try what Tony and I suggested?

If you are still having problems, then tell us what your operating system is (WIN XP, Vista, 2000, NT, etc.) and also try to describe what you did to get rid of the virus you had.
You vill print ze pages or else face ze consequences!!
As an addition to cjards advice- if you only ever use english then delete all instances of foreign keyboards so that you only have the UK keyboard- this will lessen the risk of someone accidentally switching them.

To do this goto start- control panel and select "regional languages and options"- then select the "languages tab" and then the details button- once here delete any other language keyboards.
And further to opps note, see the last part of the article; if you do have multiple languages installed, there ought to be a blue square somewhere on screen (it's on the login screen and usually near the clock) that allows you to switch keyboards on the fly.
Sponsored Links