Glow worm boiler fault code

Very interesting immortals works of Col. Clink. Two pages buy plus 4k sightings.
Sponsored Links
hi i need HELP my hubbie fitted a new glow worm boiler 3 weeks ago and it worked ok other than the pressure droped when the heating was on timed but i checked it every morning and made sure it did not go down to far .The other day i put the pressure up to 2 bar and when i turned it on the display bar showed 90 which means flashing flames or gas failure it does not explaine what to do . I have go the pressure gauge down to 1 1/2 which hubbie said it should be at and have also followed instructions for boiler lockout and it tries to start but fails CAN ANYONE HELP PLEASE
We had this fault (f4) and it was caused by the condensate pipe being blocked by ice. We think the build up of ice backs up the pipe and eventually the boiler has no-where to get rid of the water. So the boiler cant ignite and when you try to it makes a horrible gurgling/banging noise. Anyway disconnecting the condensate pipe from the boiler outlet pipe did the trick.

The water now has somewhere to go, all down the outside wall :D . Will put a more permanent fix in when the weather gets better/warmer to save the wall from getting damp.
Scatman John, you are a true star, thank you so much. What I thought was going to be a huge problem and cost me money I don't have was a minor issue solved in minutes. Thank you xx :D
Sponsored Links
Hi Guys does anybody know anything about the F15 fault code on a Glow worm 30si. Manual says Stepper motor on gas valve so i got that replaced but the same code apeared so i was advised to change the pcb, this has also failed to work!! Any clues im at a loss!!
Have the answer but howe do I take off the front cover to access the second cover so I can use the red button to reset the thermostat? :oops:
Please note that opening the inner cover ( combustion chamber ) is not a recommended procedure for a DIYer!

In any case overheating indicates an incorrect operating condition and should be investigated.


I am also getting the F5 error code. Was there a (reasonably) solution to this?

Many thanks,

DIYnot Local

Staff member

If you need to find a tradesperson to get your job done, please try our local search below, or if you are doing it yourself you can find suppliers local to you.

Select the supplier or trade you require, enter your location to begin your search.

Are you a trade or supplier? You can create your listing free at DIYnot Local

Sponsored Links