Texecom Premier 48 or Premier 48 Elite, and ComIP - help....

4 Jan 2014
Reaction score
United Kingdom
Hello noble community.

I have a question about Texecom Premier Alarms and I'm hoping there is a guru out there somewhere...

I have a Texecom Premier 48 Alarm which I installed myself. I got the panel from Ebay some time ago and it works great with the lovely Premier Elite Gunmetal Keypads. I am all sensored up and it's a great working system.

However, because I am a techie, I wanted to make the next step and so I just bought a ComIP unit to get the Alarm on the LAN and take advantage of the iPhone App and Wintex software.

But, I have a problem... I have no settings in my panel for the ComIP, and after some googling, I found out that I need Firmware V3.0 or later. The Texecom sites only talk about Premier Elite panels, and I don't think I have one of those, just a vanilla Premier 48. It's got the right COM port and connections, just no settings.

So, is it possible to take my firmware V2.0 on a Premier 48 Panel and upgrade it to V3.0 or later - and how? - and where do I get the firmware from?

Looking forward to your assistance..

Sponsored Links
Yes you can go up to v9.0 firmware,you may have to upgrade the nvm chips, you will need a flasher to do this, it may be cheaper to buy a premier elite panel if you want to use the app. There is a version 10 for the old panel to use the app but it may not be fully supported in the future.
Any idea where I get the firmware from, and am I right that as well as needing to buy a flasher that I need a pc com as well?

If I need all that, you might be right that a new elite might be cheaper in the end?
You can use the app except the smart key on the pre elite 48's unless version 10 is used, as advised previously it would probably be simpler
to go for the Elite and longer term more cost effctive.

To flash the panel to 9 or above a 256 nvm chip from my memory is needed rather than a 128.

If you press menu then 4 on the keypad in day mode it wil give you the panel and version number.

To get the app to work however will require to change the com-ip settings and program the comp-ip module on the panel as nothing fitted.

I would firstly program the com-ip as fitted connect it to the network an check you can connect with wintex.

By programming the com ip this way the panel will be populated with the local ip address, thus can then be used to connect locally or port forward on your router.

The changing the mode of the com-ip requires accesing the unit with a default access code.
Sponsored Links
Hi Hoover...

thanks for the above... let me just check if I understand you correctly....

Suppose I want to forget about the iPhone App for now, and just want to get Wintex connectivity over my ComIP... are you saying that despite the fact that I have no configuration settings in my panel (because it's V2.0 and not 3.0 or above), that I can find some way to leave COM1 to "nothing fitted", and find a way to set the ComIP to DHCP, and still have that functionality without having to upgrade the firmware...?

... or have I read too much between the lines from your reply?

I have gone to the trouble of running a LAN cable into the loft now, and I've installed a new network switch, and installed Wintex... so what's the minimum I can get away with to get Wintex running (without going all '80's and using an RS232 COM-PC. :(

thanks for comments/thoughts by the way...
** Update: **

I've just run an IP Scanner on my network, and I can see the Lantronix box (the ComIP) on my network at IP Address :)

Does anyone know if this box serves a web page to configure settings (IP Address, DHCP, Ports etc?) If so, what port is it on, and can I "simply" tell Wintex these settings and use ComIP on a V2.0 panel ?
The defualt port is 10001

Can you connect using wintex using the ip address you have specified?

If you are having trouble I could look for you by a remote session to your pc with team viewer or something and see how far we can progress, no promises mind as its an old system.

How do you have the comport configured at the moment
When you press Menu then 4 on the keypad in day mode

Does it say elite 48 v2.x LS1 OR PREMIER 48 V2.X?

As this will determine your options.
Hi Hoover

thanks again for your thoughts on this.

Pressing Menu 4 gives me "Premier 48 V2.0"

Also... I reconfigured my LAN to allow the subnet of 192.168.0.x and can now see, ping and show the port 80 webpage of the ComIP (sadly no settings on the webpage to configure it though :()

When I go to Wintex, I enter and port <anything other than 10001> and click "connect" and it returns immediately with an error that it cannot connect.
when I change the port in Wintex to 10001 and click connect, it takes a long while to return with the "cannot connect" error, and this seems to be after the status bar says "Reading Version and Configuration" (or something similar) - but I still get the error (after maybe 10 seconds).

So, because I get a long delay before the error when using Port 10001 I am concluding that it connects (at least at the Lantronix).

I then tried setting the Com1 port on the Panel to a variety of things... 300 Baud, 2400 Baud, ISDN, Modem... none seemed to work. After 10 seconds or so the wintex connection returned an error :(

The closest I got was Wintex actually flashing the Tx and Rx icon LED's a bit during the 10 seconds.... :)

I was kind of hoping that to the panel the ComIP looked just like a PC-COM (after all they should both be converting an input into TTL Serial right? (one RS232 and one LAN). But I can't even find out how to configure the panel for a PC COM.

Any further thoughts appreciated.... :)
The COM-IP should be taking its IP settings from the panel menus, but you need to configure those menus first.

If you power the panel up with the COM-IP connected to your local network and your local network has a DHCP server, then the COM-IP will receive an IP via DHCP. I always power up with the LAN cable disconnected, so the module picks up its IP from the panel.

It sounds like your panel menus haven't been configured correctly. There are quite a few threads on here regarding the COM-IP settings.
Usb com and pc com, the comport is set to not used and should work as is, as soon the com port is set for a praticular device or function these modules wont work.

The COM-IP if its available in com port setup place it on com1, do a power cycle as suggested if its not already showing an ip as outlined below.

look in udl digi options, setup modules, ip and you should see the ip address assigned.
thanks gents.... but that's my problem. I have a V2.0 Premier (non-Elite) panel, and so my settings don't have a "UDL/Digi/Setup/IP" option :(

I guess this thread started by asking how easy, and what I would need to upgrade from V2.0 to V3.0 or higher (I buy a flasher, but where do I get the firmware from, and do I also need a PC COM) ? (I have neither :()

But the thread is now discussing (quite rightly) whether I can actually get away with not having the settings in my menu on V2.0 - after all, I can see the Lantronix on my network, I can "sort of" see it in Wintex, but I cannot read any settings.

I'm going to try again by setting the Com1 to <not fitted> in the panel menu (as if connecting a PC_COM)...

any other ideas?

cheers - appreciate the Sunday advice...
Go on ebay there are some 48 pcbs for sale £12 inc delivery that's your cheapest option ( cheaper than a flasher and nvm chip )
Good idea. Thx. I just sent the seller a message to ask what version of firmware is installed.

If v3 or more, I assume I can just pull my NVM chips out and keep all my settings?

DIYnot Local

Staff member

If you need to find a tradesperson to get your job done, please try our local search below, or if you are doing it yourself you can find suppliers local to you.

Select the supplier or trade you require, enter your location to begin your search.

Are you a trade or supplier? You can create your listing free at DIYnot Local

Sponsored Links