1. Visiting from the US? Why not try DIYnot.US instead? Click here to continue to DIYnot.US.
    Dismiss Notice

Toshiba Laptop SATA HDD password

Discussion in 'Hardware' started by DIYspanner, 3 Nov 2011.

  1. DIYspanner

    DIYspanner

    Joined:
    17 Apr 2007
    Messages:
    1,947
    Thanks Received:
    77
    Country:
    United Kingdom
    My mate has given me his laptop (Satellite L330) to sort out because it has a HDD password and suddenly its not accepting the password.

    On trying to enter the password on the third attempt, the laptop switches off.

    I've pull the HDD (WD1600BEVS) out and tried plugging it in to my PC which has an Asrock K7VT4A MBoard. Plugged into Sata 1, on booting, XP is looking for a Raid contoller which I then installed from the MBoard disk.

    Rebooting, my PC switches off during boot and will only boot if I unplug the Sata drive.

    Can I assume that this Sata HDD is faulty?

    Thanks in advance for any reply posts.
     
  2. Sponsored Links
  3. joinerjohn

    joinerjohn

    Joined:
    28 Nov 2009
    Messages:
    6,145
    Thanks Received:
    201
    Location:
    Derby
    Country:
    United Kingdom
    Just looked up your mobo specs on the internet and it doesn't appear to have any SATA connectors at all. Seems to have IDE connectors though.
     
  4. DIYspanner

    DIYspanner

    Joined:
    17 Apr 2007
    Messages:
    1,947
    Thanks Received:
    77
    Country:
    United Kingdom
    My apologies, its a K7VT4A Pro MBoard not K7VT4A.

    The K7VT4A Pro has two Sata sockets and I plugged into Sata 1
     
  5. Astra99

    Astra99

    Joined:
    1 Feb 2011
    Messages:
    852
    Thanks Received:
    139
    Location:
    Gloucestershire
    Country:
    United Kingdom
    TBH it sounds more like it is the BIOS password. Unless Toshiba have added something "under the radar" I have never come across a Hard Disk password. Normally, to reset the BIOS password, (which also resets all the BIOS settings to defaults) it is necessary to remove the BIOS battery. Sometimes this BIOS battery is easy to access, sometimes it is a swine! (This is NOT the same battery as the one used to power the laptop, which is very easy to remove) I would suggest doing a web search for a maintenance manual, or at least information on the location of the BIOS battery.
     
  6. Monkeh

    Monkeh

    Joined:
    25 Jan 2010
    Messages:
    4,149
    Thanks Received:
    329
    Location:
    Cornwall
    Country:
    United Kingdom
  7. DIYspanner

    DIYspanner

    Joined:
    17 Apr 2007
    Messages:
    1,947
    Thanks Received:
    77
    Country:
    United Kingdom
    When I boot I'm presented with

    "Please enter Built-in HDD User Password"

    My mate told me its always been there and the one he types in has worked until now - now its not accepted.

    Three attempts to enter and the laptop shuts down.

    I've looked in the BIOS and under Security, there's the option to

    "Set HDD User Password"

    No joy with the BIOS!
     
  8. Monsterminty

    Monsterminty

    Joined:
    26 May 2011
    Messages:
    238
    Thanks Received:
    29
    Location:
    Pembrokeshire
    Country:
    United Kingdom
  9. DIYspanner

    DIYspanner

    Joined:
    17 Apr 2007
    Messages:
    1,947
    Thanks Received:
    77
    Country:
    United Kingdom
    On further investigation, I thinking towards HDD failure as there's no reason for the HDD to suddenly not accept the password.

    Out of curiosity, I plugged the HDD into my K7VT4A Pro based PC again and tried booting with the Linux based GParted from CD ROM and although the PC was able to see the disk when booted, it came up with read errors when I tired to check the disk's integrity.
     
  10. Sponsored Links
  11. joinerjohn

    joinerjohn

    Joined:
    28 Nov 2009
    Messages:
    6,145
    Thanks Received:
    201
    Location:
    Derby
    Country:
    United Kingdom
    You could also have plugged the HDD into the second SATA socket and tried to access it, after your computer had booted. (I'm assuming your PSU has at least 2 power connectors for SATA HDD's though) ;) ;)
     
  12. Igorian

    Igorian

    Joined:
    30 Mar 2004
    Messages:
    2,736
    Thanks Received:
    63
    Location:
    Northamptonshire
    Country:
    United Kingdom
    Something like this might be worth a punt if all else fails. I've not verified it in any way btw.
     
  13. Monsterminty

    Monsterminty

    Joined:
    26 May 2011
    Messages:
    238
    Thanks Received:
    29
    Location:
    Pembrokeshire
    Country:
    United Kingdom
    after more research, quite a few people have had problems with faulty HDDs throwing up "please put in password"(or whatever) on drives that previously had no password protection, so i would lean towards faulty too, but give Igorian's suggestion a go.
     
  14. DIYspanner

    DIYspanner

    Joined:
    17 Apr 2007
    Messages:
    1,947
    Thanks Received:
    77
    Country:
    United Kingdom
    I'm trying the MHDD method as advised above.

    Problem:
    Using v4.5, I'm struggling to invoke "command. dump" via Script. Once I'm in MHDD, there are only the generic command options.

    I've replaced the zip file as instructed!
     
  15. Monsterminty

    Monsterminty

    Joined:
    26 May 2011
    Messages:
    238
    Thanks Received:
    29
    Location:
    Pembrokeshire
    Country:
    United Kingdom
    good luck
     
  16. DIYspanner

    DIYspanner

    Joined:
    17 Apr 2007
    Messages:
    1,947
    Thanks Received:
    77
    Country:
    United Kingdom
    Quoting from the website lead above

    "
    The offsets may be different, but the sequence of bytes in the file is similar.

    0x137 offset the value 07 indicates the level of security assistance (in this case, HIGH).

    Passwords are the two fields of 32 bytes highlighted.
    "

    I'm not familiar with Hex editors so going of the quote, how many rows down and no. of columns in do the passwords start?
     
  17. Monsterminty

    Monsterminty

    Joined:
    26 May 2011
    Messages:
    238
    Thanks Received:
    29
    Location:
    Pembrokeshire
    Country:
    United Kingdom
    can you post an image i.e take a photo and upload it?
     
Loading...

Share This Page