Upstairs hot - downstairs cold, no hot water - most confused

6 Oct 2004
Reaction score
United Kingdom
Hi Gang

Here is an interesting problem - which at this moment has be baffled.

Drained down a CH/HW system, replaced a bathroom rad for a towel rail, removed a downstairs rad and re-attached it to the wall, then reconnected it to the system. Made no other changes to the system.

Filled the system - bled air from downstairs rads and then upstairs rads. System appeared to fill fine.

Fired up the boiler. As expected there was air in the system which vented from the automatic air vent installed. Then system calmed down.

Pump runs ok, controller and thermostat work fine. The pump is upstairs in the airing cupboard, boiler is on the ground floor.

All of the rads upstairs work just fine, however, those downstairs do not get hot - the supply pipe to the rad inlet is warm to the touch but this hot water does not get into the rad - yes all the valves are open.

Also, the top and bottom of the hotwater coil are very hot to the touch - 60 degrees ish, but there is no hot water being produced - yes there is water in the cylinder and it comes out tepid at best.


Sponsored Links
Thanks Kev - but how would that change anything - as before the system was drained down and re-filled all the rads worked?
you have air trapped somewhere ifthe upstairs are hot the water must be giong round i assume you have checked the pump and vented it
Sponsored Links
vented or sealed system?
Water present in the feed cistern ?
bled the pump?
bled the hot water coil?

Sounds like pump failure.
Hi guys - thanks for the quick feedback.

It's a vented system. Water is present in the feed cistern. The coil is vented via the automatic air-vent, which is situated at a high point on a 'T' above the coil i/p side.

However, I have not tried to vent the pump. I presume I need to do this via the large screw on the front?
yes undo it (slight dribble of water )and let the air out
while you have the screw out stick a screwdriver in the hole and make sure the shafts not stuck there is a groove in the top to turn it
Thanks Kev - will try first thing in the morning - any other suggestions if that's not it?

Fired the system up this morning and it worked just fine - I assume there was a small air lock which worked it's self out during the night...

Thanks for all your input.

DIYnot Local

Staff member

If you need to find a tradesperson to get your job done, please try our local search below, or if you are doing it yourself you can find suppliers local to you.

Select the supplier or trade you require, enter your location to begin your search.

Are you a trade or supplier? You can create your listing free at DIYnot Local

Sponsored Links