1. Visiting from the US? Why not try DIYnot.US instead? Click here to continue to DIYnot.US.
    Dismiss Notice

Vaillant boiler keeps switching on and off by itself

Discussion in 'Plumbing and Central Heating' started by sachintendulkar, 27 Aug 2008.

  1. sachintendulkar

    sachintendulkar

    Joined:
    27 Aug 2008
    Messages:
    14
    Thanks Received:
    0
    Location:
    Essex
    Country:
    United Kingdom
    I am wondering if someone can help with me a problem. We have a Vaillant bolier (not sure of the model because there is no sticker but it may be one of the 800 series) and whenever we switch on the hot water, it comes on as expected and hot water comes out. However, when the water is turned off, it continually keeps switching itself on and off (there is the constant humming noise when the boilers are on, the green light keeps flashing, the yellow light goes off for few seconds, then comes on, goes off, comes on, etc...). One thing I found out by complete accident was that when we open the cold water tap, it switches off and remains off until the hot water is opened again and we are back to square one.

    Can someone please shed some light on the subject? We called in a boiler "expert" and he basically said that we have a hot water leak somewhere and we need to find the leak. That was a great help. However, if that was true, then why does switching on the cold water swtiches off the boiler?
     
  2. Sponsored Links
  3. turn the hotwater dial fully anti clockwise, leave for 5 seconds then turn clockwise two thirds (no further)
     
  4. sachintendulkar

    sachintendulkar

    Joined:
    27 Aug 2008
    Messages:
    14
    Thanks Received:
    0
    Location:
    Essex
    Country:
    United Kingdom
    I should have also mentioned that it is a combi boiler and I have tried the heating setting to ON and OFF and it makes no difference. The water pressure gauge is in the middle (1.5 I think). We noticed the problem last weekend and at the same time, our main water pipe into the house developed a leak (the floor boards were very wet and in fact still haven't dried). That leak was fixed by the same guy who said that it is playing up because we have a hot water leak somewhere. Currently, we have to switch the boiler off at night because the humming noise (normal when the boiler switches on) as well as when it fires keeps us awake at night.
     
  5. you may need a new diverter valve part no 252457 if you have the turbomax plus (which it sounds like you have)
     
  6. sachintendulkar

    sachintendulkar

    Joined:
    27 Aug 2008
    Messages:
    14
    Thanks Received:
    0
    Location:
    Essex
    Country:
    United Kingdom
    Thanks for the quick response, but our hot water dial is more or less all the way to the left and has been there ever since the boiler was installed almost three years ago.
     
  7. weareleeds

    weareleeds

    Joined:
    13 Dec 2005
    Messages:
    664
    Thanks Received:
    2
    Location:
    Yorkshire
    Country:
    United Kingdom
    Has it got warmstart switched on (depending on model) to turn off move dhw selector knob to min for a couple of seconds then restore back to original position if you want warmstart back on turn same knob to max for a couple of seconds then move back to original position
     
  8. Vaillant do a fixed price repair 01773 828100 it's £215
     
  9. mickyg

    mickyg

    Joined:
    24 Aug 2005
    Messages:
    16,007
    Thanks Received:
    3,325
    Location:
    Cornwall
    Country:
    United Kingdom
    Do this, as he says. you have whats called a preheat(or warmstart as vaillant call it) function on your boiler. This is how to turn it off.
     
  10. Sponsored Links
  11. sachintendulkar

    sachintendulkar

    Joined:
    27 Aug 2008
    Messages:
    14
    Thanks Received:
    0
    Location:
    Essex
    Country:
    United Kingdom
    It is definitely not turbomax plus. I will try and find the paper work tonight to find the exact model.

    Sorry, what is the dhw selector knob? I don't remember reading anything about that in the manual.
     
  12. sachintendulkar

    sachintendulkar

    Joined:
    27 Aug 2008
    Messages:
    14
    Thanks Received:
    0
    Location:
    Essex
    Country:
    United Kingdom
    I am not at home at the moment, so I got someone else to try and turn the preheat off and the problem is still there.
     
  13. mickyg

    mickyg

    Joined:
    24 Aug 2005
    Messages:
    16,007
    Thanks Received:
    3,325
    Location:
    Cornwall
    Country:
    United Kingdom
    Maybe a leak, or faulty aquasensor. When your at the boiler, Turn off power, turn on and immediately press "i". Note down all the codes that come on the display. They will be "S" something.... then let us know what they are.
     
  14. sachintendulkar

    sachintendulkar

    Joined:
    27 Aug 2008
    Messages:
    14
    Thanks Received:
    0
    Location:
    Essex
    Country:
    United Kingdom
    OK. I will post them tonight. Are you saying that the boiler man could have been correct about the leak in the hot water pipes. He also said that was downstairs and the boiler is upstairs. If that is the case, then why does switching on cold water switches the boiler off?
     
  15. sachintendulkar

    sachintendulkar

    Joined:
    27 Aug 2008
    Messages:
    14
    Thanks Received:
    0
    Location:
    Essex
    Country:
    United Kingdom
    danger mouse was correct. It is 828E Turbomax Plus. I switched the boiler off and then on again and pressed i. It came back with a status code of S.31 and that is it.

    According to the manual the light blinks green if warmstart is on if hot water is being requested. I have already followed procedure to switch off warmstart and all hot water taps in the house were switched off.

    What I don't understand is, if there is a leak somewhere in the house, then why would switching on the cold water in any of the taps switch off the boiler?
     
  16. mickyg

    mickyg

    Joined:
    24 Aug 2005
    Messages:
    16,007
    Thanks Received:
    3,325
    Location:
    Cornwall
    Country:
    United Kingdom
    try pressing the i button when the fault is occuring. Hopefully we can establish if either the warmstart is functioning or if the boiler thinks a tap is running.
     
  17. sachintendulkar

    sachintendulkar

    Joined:
    27 Aug 2008
    Messages:
    14
    Thanks Received:
    0
    Location:
    Essex
    Country:
    United Kingdom
    I have now also tried the "i", while the fault is occurring (all water taps off in the house). When just the green light is flashing (yellow light off), it says S.10. When the yellow light comes on, it comes up with S.10, S.13 and S.14
     
Loading...

Share This Page