Vaillant eco tec plus 837 continuously 'loading'...

Discussion in 'Plumbing and Central Heating' started by SG1972, 29 Oct 2021.

  1. SG1972

    SG1972

    Joined:
    29 Oct 2021
    Messages:
    1
    Thanks Received:
    0
    Country:
    United Kingdom
    Hi,
    Any heating engineers able to help?
    Apologies if previously covered. I did try and search.
    Just arrived back from holiday and our boiler won't start up. The screen won't power up and is just continuously flashing 'loading'.
    It doesn't get as far as showing any error codes. It sounds like it's repeatedly about to fire up for a split second but then cuts out.
    ... so no hot water or central heating.
    Green flashing light on the front under the button with the circular arrows on.
    Hope that makes sense!
    Any ideas?
    Thanks in advance.
     
  2. muggles

    muggles

    Joined:
    28 Oct 2005
    Messages:
    13,431
    Thanks Received:
    3,104
    Location:
    Daventry
    Country:
    United Kingdom
    PCB has died
     
    • Like Like x 2
    • Thanks Thanks x 1
  3. Sponsored Links
  4. Harry Bloomfield

    Harry Bloomfield

    Joined:
    30 Dec 2018
    Messages:
    9,651
    Thanks Received:
    1,302
    Country:
    United Kingdom
    Or an outside chance there is an high resistance connection, on the mains electrical supply.
     
  5. ianmcd

    ianmcd

    Joined:
    15 Aug 2010
    Messages:
    24,054
    Thanks Received:
    10,133
    Location:
    Livingston
    Country:
    United Kingdom
    +1 for PCB
     
    • Thanks Thanks x 1
  6. Sponsored Links
  7. CBW

    CBW

    Joined:
    26 Sep 2019
    Messages:
    9,796
    Thanks Received:
    2,688
    Location:
    North
    Country:
    United Kingdom
    +2 for pcb, don’t think I’ve known it to be anything else.
     
    • Thanks Thanks x 1
Loading...

Share This Page