Vaillant ecoTEC 937 not repressurising

10 Dec 2010
Reaction score
United Kingdom
I have just bled all my radiators and have lost pressure on the radiator system to 0.6 bar, just below the 0.7bar required for the central heating to fire.

There are two grey valves beneath the boiler for repressurizing

I have turned both to the on position (and tried every possible combination of positions) and the system won’t repressurise. I can’t hear any water flow into the system ( with my ear pressed against the boiler!) and the readout is stuck on 0.6bar.

Any suggestions how I what I might be doing wrong?

Many thanks
Sponsored Links
If either (or both) lever was stiff to turn I'd suspect the grey plastic cap has cracked / sheared where it covers and turns the brass valve stem. Try taking the plastic covers off and turning the valve stems with spanner / grips / pliers.
Sponsored Links
Mate, just took the plastic caps off and turned the valve with a screwdriver. It worked. Pressure back and boiler working.

Thank you very very much.

DIYnot Local

Staff member

If you need to find a tradesperson to get your job done, please try our local search below, or if you are doing it yourself you can find suppliers local to you.

Select the supplier or trade you require, enter your location to begin your search.

Are you a trade or supplier? You can create your listing free at DIYnot Local