Yale HSA6400 alarm

25 Jan 2011
Reaction score
United Kingdom
The ‘Faulty display Led’ is illuminated on my Yale HSA6400 Alarm system and it beeps every 30 seconds. I assumed that there must be a low battery condition in one of the 5 PIRs or 2 door sensors. The only other devices on the system were two keyfobs but have removed them from the system. However none of the PIRs flash when walking across the front of them. Neither of the Door alarms flash on opening the door.

The instruction book states that setting the Alarm or Home alarm will display the device at fault but I tried setting both of them and there was no fault display.

I have checked that the power supply is OK (14v). None of the devices have been tampered with.

How do I determine what the fault is?

Thanks, Peter Scott
Sponsored Links
I have managed to solve the problem. I went into the Fault log and deleted the reports one by one. I deleted them all expect the hall PIR which would not delete. So there was the culprit. Changed the battery and all restored to normal now.

The instruction book for this alarm is apalling.

Well done just spotted this now or would have given advice to go into fault log and then immediately exit confirming clearing faults and then as you say only any active faults remain on show...and can then be dealt with.
Well thanks for thinking about my problem. The real problem is the instruction manual. I only found out how to clear the fault log by accident.

I have just written myself an instruction page on the 'Fault led' and battery changing. My memory is not very good, so an aide memoire will save time the next time the beeping starts.
Sponsored Links
May I tag onto this query please?

I have had my alarm for 2 years and it has worked well both using the control panel and remote to arm/disarm.

Time came to replace the batteries, and now all have been done. But I am unable to remove the tamper alert for the PIR's. This results in the amber lamp glowing all the time and the alarm needing to be switched on manually via the double press and tick for the red button. This condition will not submit to re-programming and I am unable to use the remote at all. Any ideas on how to fix it, or will I have to set back to default and 'learn-in' all the gismos again ?


If you have cleared the fault log then only the problem device should show up as mentioned above.

Try taking the front off and putting ot back on again.

Failing that try removing the device from the system by using remove device option and then adding it back into the system via add device.
MDF some good suggestions there thanks. So you too, don't think its as straightforward as it might be !

I have already re-set the PIR so your suggestion of deleting it electronically and then learning-in again makes good sense.

My thanks for your care.
A little late but an update anyway.

I deleted the PIR from the circuit and re-learned it back in again, but it made no difference. So I changed the batteries - even though this fault occurred as soon as I had fitted a new set of batteries. But this worked and the red led flashed and I was able to learn it back into the circuit again.

I used a fresh pack of 6 batteries to do both PIR's originally, the other PIR having shown no fault at all since fitting them. So this remains a mystery.

But no matter, it works now thanks to the help I received here, many thanks.
Thanks for the update...

Just a mention Dura Cell batteries are notoriously finnicky in the PIR sensors. For whatever reason they are a bad and intermittent fit.
I always reccommend using batteries other than duracells.

Just noticed this post, smack on with the battery bit, just read the last post only, I've found the same problem myself .... Not with Yale mind, which I know nothing about.

DIYnot Local

Staff member

If you need to find a tradesperson to get your job done, please try our local search below, or if you are doing it yourself you can find suppliers local to you.

Select the supplier or trade you require, enter your location to begin your search.

Are you a trade or supplier? You can create your listing free at DIYnot Local

Sponsored Links