24CDi problem

B

bigmouk

Hi,

Hoping someone can offer some advice as I move house this week and the boiler has just started to play up.

It started last week with a strange issue with the hot water. The heating was fine but when demand was sent for hot water the CH indicator started to flash rapidly. Later that morning it was fine and has been fine since.

Last night I noticed the heating hadnt turned off when expected. I reset everything, turned up the stat and the boiler kicked in fine. I turned down the stat and it took 1 to 2 mins for the boiler to turn off even though the stat had sent the signal to stop. The boiler then continued to make a low humming noise like something was turned on - no flame through the spyhole. I turned the boiler off, left it 10/20 secs and turned back on (humming noise gone) but the CH indicator was flashing slowly. I held the reset button for a few seconds and it seemed to reset itself.

Hot water was fine this morning but havent tested the heating.

Anyone seen these issues before ?

Thanks in advance!
 
Sponsored Links
Joined
26 Jun 2004
Messages
64,176
Reaction score
4,644
Location
London
Country
United Kingdom
Its possible a temperature sensor is faulty or has a bad connection and in some fault senarios is making the boiler operate in frost protection mode.

If this is the case then its one of the least expensive possibilities.

Tony
 
B

bigmouk

Thanks Tony.

Does the low humming noise mean frost protection mode ? The green power light was on but no other indicators lit and no flame.

Do you think its worth changing the stat first to a simple wired one? I have a 7 year old wireless unit that has given me issues in the past. Yesterday I changed the batteries for brand new ones and went through the binding procedure again to make sure it was setup from scratch.

The boiler is 12 years old and I've had it for 7 years, in that time its had a few things done, new vessel, o rings that i can remember. Generally runs really quiet without any problems.
 
Joined
26 Jun 2004
Messages
64,176
Reaction score
4,644
Location
London
Country
United Kingdom
Frost protection usually has two stages!

Below 5 C it just runs the pump and below 2 C it brings on the burner.

Tony
 
Sponsored Links
B

bigmouk

The humming noise was the pump run off so I'm told. Just tested and all seems ok now, the humming stops after a few minutes. Because I turned the boiler off last night while the pump was going, when I turned it back on I think it was registering that as a fault hence the flashing light.

I think the wireless thermostat unit I have sometimes has a fit, maybe when the batteries are low. I've had it about 6/7 years now and something similar has happened before when the batteries were low.

All seems good for the moment touch wood!
 

DIYnot Local

Staff member

If you need to find a tradesperson to get your job done, please try our local search below, or if you are doing it yourself you can find suppliers local to you.

Select the supplier or trade you require, enter your location to begin your search.


Are you a trade or supplier? You can create your listing free at DIYnot Local

 
Top