A very Intermittent Ravenheat RSF 100ET

Joined
25 Oct 2016
Messages
4
Reaction score
0
Location
London
Country
United Kingdom
I have a RAVENHEAT RST 100ET that is very intermittent. Whether on Heat or Hot water, the Fan and motor run fine but doesn't always fire. After a couple of more tries it still may or may not fire. If it doesn't the red light comes on. After resetting, again same situation. Sometimes it will work fine for a couple of days, at other times after resetting some 20 times, it will suddenly work ok. I don't hear it firing either. Relay 3 just will not operate. Very occasionally it will fire and light for a split second, then fail again. I've replaced both thermistors and I've checked the air-pressure switch by blowing into the pipe that goes into the flue and it works fine. Got a second hand tested control board this morning, but same issues persist so I assume board is fine. I can't find a circuit diagram on line that shows exactly the same board. Is there any way of checking the gas switch and the electrode cables? Any other suggestions are most welcome!
 
Sponsored Links
Joined
28 Oct 2005
Messages
13,595
Reaction score
3,218
Location
Daventry
Country
United Kingdom
Sorry but you've already gone beyond what a DIYer should be doing and forum rules prohibit advice on this kind of stuff. Time to call in a professional
 
Joined
2 Aug 2010
Messages
6,196
Reaction score
1,210
Location
Manchester
Country
United Kingdom
I have a RAVENHEAT RST 100ET that is very intermittent. Whether on Heat or Hot water, the Fan and motor run fine but doesn't always fire. After a couple of more tries it still may or may not fire. If it doesn't the red light comes on. After resetting, again same situation. Sometimes it will work fine for a couple of days, at other times after resetting some 20 times, it will suddenly work ok. I don't hear it firing either. Relay 3 just will not operate. Very occasionally it will fire and light for a split second, then fail again. I've replaced both thermistors and I've checked the air-pressure switch by blowing into the pipe that goes into the flue and it works fine. Got a second hand tested control board this morning, but same issues persist so I assume board is fine. I can't find a circuit diagram on line that shows exactly the same board. Is there any way of checking the gas switch and the electrode cables? Any other suggestions are most welcome!


Your boiler is a piece of **** 15 plus year old scrap box landlord special, they’re throw away boilers. Get someone is who know what they’re doing to repair or better still replace with something decent.
 

DIYnot Local

Staff member

If you need to find a tradesperson to get your job done, please try our local search below, or if you are doing it yourself you can find suppliers local to you.

Select the supplier or trade you require, enter your location to begin your search.


Are you a trade or supplier? You can create your listing free at DIYnot Local

 
Sponsored Links
Top