1. Visiting from the US? Why not try DIYnot.US instead? Click here to continue to DIYnot.US.
    Dismiss Notice

Boiler pressure cold tap not working problem

Discussion in 'Plumbing and Central Heating' started by lea_nne_, 27 Aug 2021.

  1. lea_nne_

    lea_nne_

    Joined:
    27 Aug 2021
    Messages:
    6
    Thanks Received:
    0
    Country:
    United Kingdom
    Hi everyone,

    I went to top up my Logic S15 boiler earlier as the pressure gauge was at zero. I’d done this before so I knew to expect to hear rushing water through the pipes when i turned the valve, but I heard nothing. I unscrewed the filling loop because i thought that might be the issue, but the filling loop was clear and it was the tap that wasn’t letting any water through. By now, I’d already moved some of the other valves and couldn’t work out what they’d looked like before, so I couldnt return them to their open/closed positions. Any way I turn the one connected to the cold pipe doesn’t allow water out, though.


    I read online that there might be a leak causing the pipe to not let cold water through, but all the other taps in the house are letting water out at their maximum pressures — like normal, basically. I’m wondering if there’s something I’m missing or an easy fix for all of this before I call someone to help. I’ve attached some pictures here: https://imgur.com/a/48U3TlP


    Thanks!!
     
  2. Sponsored Links
  3. cross thread

    cross thread

    Joined:
    8 Sep 2005
    Messages:
    1,589
    Thanks Received:
    263
    Location:
    worlds end
    Country:
    United Kingdom
    The cold inlet isolation valve on some ideal boilers is a 3way ,off/cold water on / position for passing water to filling loop so would think yo have it in wrong position
     
    • Like Like x 1
  4. CBW

    CBW

    Joined:
    26 Sep 2019
    Messages:
    8,375
    Thanks Received:
    2,190
    Location:
    North
    Country:
    United Kingdom
    It looks as though the flow and return valves (black handles) are closed? Also your gas isolation valve (yellow handle) looks closed.
     
    • Like Like x 1
  5. lea_nne_

    lea_nne_

    Joined:
    27 Aug 2021
    Messages:
    6
    Thanks Received:
    0
    Country:
    United Kingdom
    Thank you, I’ll try to get it into a different position and see what happens
     
  6. lea_nne_

    lea_nne_

    Joined:
    27 Aug 2021
    Messages:
    6
    Thanks Received:
    0
    Country:
    United Kingdom
    Thank you haha, I’ve turned them all in the opposite direction now
     
  7. CBW

    CBW

    Joined:
    26 Sep 2019
    Messages:
    8,375
    Thanks Received:
    2,190
    Location:
    North
    Country:
    United Kingdom
    And, does it now fill?
     
  8. Sponsored Links
  9. lea_nne_

    lea_nne_

    Joined:
    27 Aug 2021
    Messages:
    6
    Thanks Received:
    0
    Country:
    United Kingdom
    no, unfortunately…
     
  10. CBW

    CBW

    Joined:
    26 Sep 2019
    Messages:
    8,375
    Thanks Received:
    2,190
    Location:
    North
    Country:
    United Kingdom
    Sounds like the cold side might have failed, it has a double check valve inside, which may have failed, or the ball inside no longer turns. You can purchase new ones, and by the sounds of it, you sound capable enough to replace it.
     
  11. jeff the gasman

    jeff the gasman

    Joined:
    8 Dec 2007
    Messages:
    13,368
    Thanks Received:
    4,815
    Location:
    Cheshire
    Country:
    United Kingdom
    Flow and return were on. Gas was off.
     
    • Thanks Thanks x 1
  12. lea_nne_

    lea_nne_

    Joined:
    27 Aug 2021
    Messages:
    6
    Thanks Received:
    0
    Country:
    United Kingdom
    haha thank you, i will try and get that sorted ASAP:)
     
  13. lea_nne_

    lea_nne_

    Joined:
    27 Aug 2021
    Messages:
    6
    Thanks Received:
    0
    Country:
    United Kingdom
    finally fixed that, thank you!
     
    • Like Like x 1
Loading...

Share This Page