Burner failure of Baxi Combi 80Eco

Joined
4 Jan 2007
Messages
2
Reaction score
0
Location
Cheshire
Country
United Kingdom
I have a Baxi Combi boiler which has been working fine for the past 12-months, however a fault has developed on the burner. Basically whenever I now turn on the system either manually or via the timer, the boiler goes through the usual start up motions, the system clicks, the ignition sparks (visible through the window) however the gas flow/feed does not come through and the system shuts down and the red light appears. If I reset the system and do it again, the same thing happens. The only way to actually get the gas flow through (and yes I have plenty of Gas on the meter) is to turn on the hot water taps and start to fiddle/twist/tweak the radiator and hot water knobs on the unit. Eventually after about 3-5 minutes of resets and knob turning the gas appears and the unit ignites. Once the unit is on, it appears to be fine.

Can anyone explain what the problem is? Will the fact I am on a gas meter affect the supply to the system?

P.S. The gas pressure and radiator system is fine

All help appreciated
 
Sponsored Links
Sponsored Links
Joined
4 Jan 2007
Messages
2
Reaction score
0
Location
Cheshire
Country
United Kingdom
Unfortunately it's not under warrenty, I've only been living in the house for the past 12months, but the boiler is probably about 4 years old.

I'll check the electrics and see if that is the issue
 

DIYnot Local

Staff member

If you need to find a tradesperson to get your job done, please try our local search below, or if you are doing it yourself you can find suppliers local to you.

Select the supplier or trade you require, enter your location to begin your search.


Are you a trade or supplier? You can create your listing free at DIYnot Local

 
Top