citroen picasso fuel problems please help

Joined
11 Sep 2012
Messages
4
Reaction score
0
Location
Cheshire
Country
United Kingdom
hi i have citroen picasso xsara 2002 2.0 diesel hdi
the problem i have is the car is the fuel pump is pulsing which in turn is making the glowplug relay pulse and the red relay is pulsing
i have replaced with new ......battery,fuel pump,fuel filter,glow plugs. temperature sensor,
tryed second hand relays and ones of a 51 plate picasso which i know to work but this hasnt solved the problem
could it be the ecu that is faulty
please help its driving me nuts
julie x

Read more: http://www.diynot.com/forums/automo...ems-please-help.336812/#2508071#ixzz26I7fAhI6 :idea:
 
Sponsored Links
Joined
7 Feb 2008
Messages
23,651
Reaction score
4,704
Location
Northumberland
Country
United Kingdom
Obviously this has to be a huge stab in the dark Julie, but the main injection pump on PSA vehicles is known for giving problems, and since you've replaced the in tank pump (hopefully with a brand new one) and done the rest of the sensible tasks then its time to call the artillery.
Can I suggest you call BBA-Reman on 01634 687222 and explain the symptoms to them?
John :)
 
Joined
23 Sep 2010
Messages
2,203
Reaction score
484
Country
Ireland
hi i have citroen picasso xsara 2002 2.0 diesel hdi
the problem i have is the car is the fuel pump is pulsing which in turn is making the glowplug relay pulse and the red relay is pulsing

Sorry I'm confused, could you explain the problem again please? Will the car run? Do the relays switch on and off?

Did you consider getting someone to read the fault codes for you?
 
Joined
7 Feb 2008
Messages
23,651
Reaction score
4,704
Location
Northumberland
Country
United Kingdom
I'm not sure if any fault codes would be stored with this one, and the OP doesn't mention them.....to my simple mind, the tank fuel pump is pressurising the fuel line up to the main injector pump, but then the pressure decays causing the pulse - either due to a pressure sensing device issue or the fuel is simply returning to the tank.
John :)
 
Joined
11 Sep 2012
Messages
4
Reaction score
0
Location
Cheshire
Country
United Kingdom
hi no the car is trying to start but no fuel is coming from the pump all lines are clear its had a new fuel pump (the one in the tank) as soon as you turn the car on the fuel pump is just pulsing which in return is making the glow plug relay pulse
a guy is has been round and put a meter on the car an no faults have come up on the thing
julie
 
Joined
7 Feb 2008
Messages
23,651
Reaction score
4,704
Location
Northumberland
Country
United Kingdom
If one of the fuel lines is disconnected - say at the filter - the fuel pump should run for around 10 sec and then stop. Does this happen?
John :)
 
Sponsored Links
Top