Creda Sunhouse Storage Heater Model 79353 Does this have a r

9 Sep 2011
Reaction score
United Kingdom
Creda Sunhouse Storage Heater Model 79353 Does this have a reset button?

My heater packed up last week, I checked the thermal fuse which is fine. I changed it still so to be sure this wasnt the problem but still no heat?

Any ideas? Does this heater have a reset button perhaps?
Sponsored Links
I have replaced fuse 0851081, which is the only fuse link I can see on this model.
Looking at the url you kindly sent me there does suggest there's 2 fuse links but this looks to be for different models of storage heaters.

4 Thermal Fuselink - Red 0851081 for models 79149 / 59 - 79343 / 53
4 Thermal Fuselink - Yellow 0851082 for models 79169 / 79363

Or have I got this wrong... ??? Please help?
Sponsored Links
Hi, all I know is there's power going to all other heaters. All other heaters are working fine. All household electrics appears to be fine.
It's real strange how the heater has just stopped working, blown thermostat or fuse link then I'd understand... That's why I was thinking perhaps there's a reset button to press?
I'm not sure if the reset buttons exist on this model?
I'm not sure if the reset buttons exist on this model?
Not an expert on the model but I wouldn't think so - normally just bi-metal strips.

You seem to have started at the wrong end of the circuit.
Have you checked the fuse? Storage heaters normally have one each in a second fuse box.
Could be a loose/burned wire connection anywhere but most likely in the wall switch.
You really need a voltage tester to find out where there is power.
Thanks for the info, I will check the radiator fuse box and see if I notice anything odd looking or that meets your description.

Bang goes the reset button option... If only!

Does anyone else have any ideas on where I can look for faults...

Many thanks!
Fluff and dust between the contacts of the thermostat is a frequent fault.

To repair this would I lightly clean this with a brush, or would I need a new thermostat?

The inside of the heater was covered in dust...

And where is the thermostat located on this model, do you know? At the top or bottom?
Hi Matt, cheers for your comments.

Looking at that link It suggests CREDA SUNHOUSE - 79343S / 79353S / 79363S - Manual

I thought as it listed model 79353 then this would apply to my model of heater, would it not. It would be great if you could confirm?

I'm slowly building my knowledge on this subject thanks to you guys.

I've checked the thermal fuse, I've even replaced the fuse but it didnt make a difference so I don't imagine that could be the problem.
Hi natedog321,

I'm wondering if you ever got to the bottom of this? I'm in exactly the same position - same heater, same problems - everything.

Please let me know if you solved it!

DIYnot Local

Staff member

If you need to find a tradesperson to get your job done, please try our local search below, or if you are doing it yourself you can find suppliers local to you.

Select the supplier or trade you require, enter your location to begin your search.

Are you a trade or supplier? You can create your listing free at DIYnot Local

Sponsored Links