1. Visiting from the US? Why not try DIYnot.US instead? Click here to continue to DIYnot.US.
    Dismiss Notice

Danfoss HSA3 not functioning properly

Discussion in 'Plumbing and Central Heating' started by Martin lear, 28 Oct 2018.

  1. Martin lear

    Martin lear

    Joined:
    28 Oct 2018
    Messages:
    3
    Thanks Received:
    0
    Country:
    United Kingdom
    I have a danfoss hsa3 with 3 way valve. In the last month it has stopped functioning correctly.

    Now when CH is called only the motor winds, clicks the midway micro switch briefly then clicks back slightly past the switch turning it off again.

    If HW and CH are called then it’s both work.

    HW works fine on its own (default position I know).

    I have changed the HSA3 for a new one but get the same problem.

    I have looked at all the wiring in the box and Connected to my Nest control unit and it all appears fine.

    Have I just been unlucky and bought a faulty motor to replace the other!?
     
  2. polesapart

    polesapart

    Joined:
    27 May 2011
    Messages:
    1,361
    Thanks Received:
    350
    Country:
    United Kingdom
    The whole valve or the actuator head only?
     
  3. Sponsored Links
  4. Martin lear

    Martin lear

    Joined:
    28 Oct 2018
    Messages:
    3
    Thanks Received:
    0
    Country:
    United Kingdom
    The actuator only. Head is moving freely and actuator still does it when off the valve.
     
  5. ianmcd

    ianmcd

    Joined:
    15 Aug 2010
    Messages:
    23,401
    Thanks Received:
    9,649
    Location:
    Lanarkshire
    Country:
    United Kingdom
    when the actuator is moving from HW only to CH only, the short on off that you describe is supposed to happen it is not a fault
     
  6. Sponsored Links
  7. Martin lear

    Martin lear

    Joined:
    28 Oct 2018
    Messages:
    3
    Thanks Received:
    0
    Country:
    United Kingdom
    It’s not the problem. The problem is calling CH only. It passes the microswitch you hear the click and the pump start for a second or two then it moves back approx 2-3mm passed the microswitch turning the pump off.
    It most definitely isn’t working correctly.
     
  8. DIYnot Local

    DIYnot Local

    Joined:
    3 Sep 2019
    Country:
    United Kingdom

    If you need to find a tradesperson to get your job done, please try our local search below, or if you are doing it yourself you can find suppliers local to you.

    Select the supplier or trade you require, enter your location to begin your search.


    Are you a trade or supplier? You can create your listing free at DIYnot Local

     
Loading...

Share This Page