Dripping tundish after recharging every 3 months

Discussion in 'Plumbing and Central Heating' started by jonstatt, 22 Jan 2010.

  1. jonstatt

    jonstatt

    Joined:
    22 Jan 2010
    Messages:
    17
    Thanks Received:
    1
    Location:
    Hertfordshire
    Country:
    United Kingdom
    I have an OSO (Megaflo) sealed system.

    The problem I am having is that every 3 months, I see dripping in the tundish (only while heating the water) and I need to recharge the air gap in the cylinder. After doing so, the dripping stops completely. Then 3 months later it starts again.

    So somehow by air gap seems to be depleting faster than normal. Can anyone identify any reasons why that should happen?

    My house is a fairly new build, and the next door neighbour interestingly has exactly the same issue. But two doors down it is fine.

    The system is fitted with a secondary return for the hot water recirculation. I don't know if that could be an influencing factor in the premature air gap loss.

    I don't believe the valve is weak because I also notice once the dripping starts an initial surge of pressure at any hot water tap in the house until the water is left to run for 20-30 seconds.

    Any ideas would be appreciated
    Thanks
    Jonathan
     
  2. DIYnot Local

    DIYnot Local

    Joined:
    3 Sep 2019
    Country:
    United Kingdom

    If you need to find a tradesperson to get your job done, please try our local search below, or if you are doing it yourself you can find suppliers local to you.

    Select the supplier or trade you require, enter your location to begin your search.


    Are you a trade or supplier? You can create your listing free at DIYnot Local

     
  3. Sponsored Links
Loading...

Share This Page