Economy 7 problems


6 Jul 2004
Reaction score
United Kingdom
Hi all, hope you can give some assistance.

My economy 7 storage heater seems to have stopped working.

I have tried wiring in a spare storage heater (I originally had two storage heaters but removed one as it was blocking the hallway) but this did not work either. Nor did wiring either heater into the hall point.

This led me to think that their may be a problem with the economy 7 system (it is on a separate consumer unit) although it is successfully heating my water overnight.

To try to test the wiring point I wired in a kettle and tried to boil some water during the economy seven period but nothing happened.

Obviously have checked the fuses (which are all OK)...any suggestions where next to look???

Many thanks,


PS don't you just love getting up in the night to test these circuits...
Sponsored Links
how many fuses are there in the economy 7 fusebox?
what rating are they
and how are they marked?

also check all the connections in the economy 7 fuse box are tight and properly in theier terminals

also what exactly are theese wiring points you mentioned?
just plain flex outlets?
fused conection units?
switched fused connection units?
There are 3 fuses in the economy 7 fuse box, all with 15Amp cartridge type fuses.
The "point" is just a simple plain flex outlet that you wire the heater into, no switches or fuses.

Am I right in thinking that the kettle should work when I wire it into this circuit during the economy 7 hours?


yes it should work

it seems very odd that your immersion heater would be working and yet both the storage heater points would be dead

check the wiring in the fusebox...

failing that i would say its time to replace that fusebox with a moden din rail unit
Sponsored Links
It is certainly confusing me.

As well as testing with the kettle wired in, I also tested the circuit with a mains tester, and it appeared to show that the circuit was live (i.e. the light came on). Could it be that the circuit is supplying insufficient power to heat the kettle/storage heater, but enough for the circuit tester?

Probably my last thought before calling in the experts...


Hi Mark,

I can think of three possible reasons. Apologies if this is stating the obvious but for completeness its worth restating.

Heater’s thermostat is off/too low. Heater is broken or the supply flex is broken / disconnected. The time switch could be running ahead/behind the real time. Effectively your economy 7 hours have slipped – hence the test you did could have been when the time switch was still off.
Hence possibly still a problem with the heater.

There is a problem with the supply from the fuse box to the wall connector. You have checked the fuse. Therefore the next check is the continuity of the circuit. (See below)

3) There is a problem with the timeswitch/REC service itself. Unlikely since I’m assuming your water is of the economy 7 supply? Worth double checking though it could have been swapped by a previous resident etc.


SAFETY FIRST. Its not a good idea to test/diagnose on a live circuit especially late at night. Wiring in a kettle – without a fuse is inherently dangerous. I’ve described a safer way to test below. If however you aren’t able to follow or don’t feel comfortable doing it I would recommend calling in a professional. That said:-

You need to obtain (or should really have if you work with electricity) a multi meter or continuity tester. They both check circuits for connection / completeness using low battery voltages.

The basic test is to firstly isolate the e7 fusebox at its main switch and remove the fuses (noting order).

Next test the earth continuity from the heaters chassis to a local socket. (Find non painted screw works best). If there is no earth continuity I would not go further until you have found the problem with that.

If the heater has an earth connection next checks the continuity between the conductors (Live & Neutral.). This is best done by joining the two wires at the wall plate and then testing the continuity between them at the consumer unit.

(Remember the consumer unit may still have live connections on the incoming side of the isolator!)

If there is no connection between the live & neutral it indicates a circuit break, bad connection broken wire etc.

You can also continuity test the fuses whilst they are out.

Reconnect the live & neutral in the wall plate before re-energising the system.

If the wiring passes the test then the problem is going to be in the heater flex, heater or supply.

Hope this is useful.

Finally (sorry to be a bore but ...) it may be worth having a professional inspection they will not only test this circuit but ensure all your wiring is safe/up to the lattest regulations.

Good luck.
Thanks BN for the comprehensive reply.

I was wondering whether I could rule out the heater by wiring it into a plug (with fuse) and simply plugging it into a socket? This should then (after a while) heat up?

Is this a good idea?

I wired the storage heater to a plug last night and it worked!

I am guessing that this now firmly rules out the heater as having a problem (confirmed by Dimplex). As the e7 immersion heater works the e7 supply must also be OK, which leaves a fault somewhere between the consumer unit and the wall connector (as proved by the kettle/heater not working).

BN - you mentioined continuity testing the supply to the wall connector with a circuit tester. When I tested the e7 storage heater circuit during the e7 hours with a cirtuit tester (cheap screwdriver tester) it lit up, I assume that this implies continuity?

Anyone with any further ideas????


mjr said:
BN - you mentioined continuity testing the supply to the wall connector with a circuit tester. When I tested the e7 storage heater circuit during the e7 hours with a cirtuit tester (cheap screwdriver tester) it lit up, I assume that this implies continuity?

No, it simply implies there is some potential between whatever you touched and earth, via yourself.

mjr said:
Anyone with any further ideas????

Read brown-nought's post again. It's quite informative. ;)
Thanks dingbat,

Have re-read BN's post and will perform an earth & continuity check later today. Will let you know the results...


Have now checked the continuity of the circuits. The e7 immersion circuit was fine (as expected), however both storage heater black (neutral) inputs were in a bad way with the insulation all cracked and degraded (one had even sheared). I have cut the cables back beyond the damaged area and rewired. Hopefully this will have solved the problem.

I am a little worried about the cause of this - any ideas?

(Previously on inspecting the storage heater I noticed an element had blown - could this have caused the damaged cable?)

Many thanks for the help.


DIYnot Local

Staff member

If you need to find a tradesperson to get your job done, please try our local search below, or if you are doing it yourself you can find suppliers local to you.

Select the supplier or trade you require, enter your location to begin your search.

Are you a trade or supplier? You can create your listing free at DIYnot Local

Sponsored Links