Flashing red and purple lights on Salus RT505tx receiver

Joined
19 Nov 2021
Messages
3
Reaction score
0
Country
United Kingdom
Hi,

Hoping someone can help me as I've pored over various threads and can't find a solution.

I've recently moved into a house which has Ideal combi hooked up to Salus RT505tx receiver. HW and radiators have worked fine since yesterday, when the receiver, which was formerly lit with blue and green lights, now flashes purple (top) and red (below).

HW continues to work, predictably (maybe fairly too) Ideal say not their issue and need to contact Salus. The Salus number has sent me down a warren of options on the phone, none of which feature my particular model, while the knowledge base is coming up empty too.

I *think* it might be a pairing issue based on the threads but can't see any mention of a purple light.

Does anyone have a fix? Good news is the boiler still works but bad news is temp is dropping tonight and would be nice to have working central heating for that!

Thanks,

FJ
 
Sponsored Links
Without any knowledge of the stat, so could definitely be wrong!
But, are you sure it's not flashing blue?
A flashing blue with a lit red underneath, could easily appear to be purple! :)
 
Fair point, I recall the blue was quite bright but there may be an effect with the red underneath. I've added a screenshot as a guide.

If it is blue (or purple) could anyone still someone shed light on the fix? Many thanks
 

Attachments

  • Salus pic.PNG
    Salus pic.PNG
    494 KB · Views: 161
Sponsored Links
Although this doesn't relate to your model, I suspect the procedure will be similar!
Yes, hopefully a simple DIY job! :)
 

DIYnot Local

Staff member

If you need to find a tradesperson to get your job done, please try our local search below, or if you are doing it yourself you can find suppliers local to you.

Select the supplier or trade you require, enter your location to begin your search.


Are you a trade or supplier? You can create your listing free at DIYnot Local

 
Back
Top