Salus thermostat not working help

Discussion in 'Plumbing and Central Heating' started by Flixy123, 22 Nov 2021.

  1. Flixy123

    Flixy123

    Joined:
    22 Nov 2021
    Messages:
    2
    Thanks Received:
    0
    Country:
    United Kingdom
    Hi

    Please help!

    I have the salus Rt505tx and no heat... The thermostat appears to be working but the receiver does not... There is a red light and ticking sound and no heating (hot water is fine) I've tried pairing, removing batteries and turning on and off again and still nothing! Please help it's cold!!

    Thanks
     

    Attached Files:

  2. ianmcd

    ianmcd

    Joined:
    15 Aug 2010
    Messages:
    23,972
    Thanks Received:
    10,074
    Location:
    Livingston
    Country:
    United Kingdom
    sadly salus are very poor, try turning the thermostat to minimum temp, leave for ten seconds, then turn to maximum and wait ten seconds does it now talk to the receiver and bring the boiler on ?
     
    Last edited: 22 Nov 2021
  3. Sponsored Links
  4. Exedon

    Exedon

    Joined:
    2 Oct 2021
    Messages:
    189
    Thanks Received:
    57
    Location:
    North Notts/South Yorkshire
    Country:
    United Kingdom
    If you have let original battery's go flat and just put new ones in.
    Take battery's out wait 20 minutes or so (capacitor needs to discharge) Put battery's back in,battery's must be good quality alkaline cheap zinc carbon or rechargeable will not do.
     
  5. Flixy123

    Flixy123

    Joined:
    22 Nov 2021
    Messages:
    2
    Thanks Received:
    0
    Country:
    United Kingdom
    Unfortunately replacing batteries with good quality ones also didn't help... I have bought a new receiver... Hopefully this will resolve the issue!
     
  6. Sponsored Links
Loading...

Share This Page