Salus thermostat not working help

Joined
22 Nov 2021
Messages
2
Reaction score
0
Country
United Kingdom
Hi

Please help!

I have the salus Rt505tx and no heat... The thermostat appears to be working but the receiver does not... There is a red light and ticking sound and no heating (hot water is fine) I've tried pairing, removing batteries and turning on and off again and still nothing! Please help it's cold!!

Thanks
 

Attachments

  • IMG_20211122_125736.jpg
    IMG_20211122_125736.jpg
    136 KB · Views: 264
  • IMG_20211122_125704.jpg
    IMG_20211122_125704.jpg
    85.8 KB · Views: 384
Sponsored Links
sadly salus are very poor, try turning the thermostat to minimum temp, leave for ten seconds, then turn to maximum and wait ten seconds does it now talk to the receiver and bring the boiler on ?
 
Last edited:
If you have let original battery's go flat and just put new ones in.
Take battery's out wait 20 minutes or so (capacitor needs to discharge) Put battery's back in,battery's must be good quality alkaline cheap zinc carbon or rechargeable will not do.
 
Sponsored Links
Unfortunately replacing batteries with good quality ones also didn't help... I have bought a new receiver... Hopefully this will resolve the issue!
 

DIYnot Local

Staff member

If you need to find a tradesperson to get your job done, please try our local search below, or if you are doing it yourself you can find suppliers local to you.

Select the supplier or trade you require, enter your location to begin your search.


Are you a trade or supplier? You can create your listing free at DIYnot Local

 
Back
Top