Gas boiler pushing hot water to taps but not bath?

27 Dec 2010
Reaction score
United Kingdom

My gas boiler (an Alpha 240p) has just started to not give any hot water to the bath taps. The other hot water taps in the flat are fine...plentiful hot water.
When I put the hot water bath tap on, for a few seconds the water is hot, and then the water just begins to stop running and turns into a trickle and goes cold. Not of the other taps seem to have this problem. Even the cold water bath tap is fine: has a lot of pressure etc. The pressure in the boiler looks fine too: the needle is in the green (good) zone.

Any ideas what the problem might be?

thanks for any help!
Sponsored Links
Nothing to do with the boiler! Boiler does not PUSH water. It is not a pump. Water flows through it. It is the water that RUNs from the hot tap, and is flowing THROUGH the boiler that tells the boiler to get on with it as you are in need of hot water
Sponsored Links
I took the taps apart as far as I could and tried to lube the mechanism a bit with wd40. Not knowing anything about plumbing or taps I was a bit lost and couldn't see anything wrong with the taps. It tried to undo the mixer tap from the bath itself to have a proper look at what might be wrong but it was almost impossible to get a spanner in there to do it.
Anyhow, when I put the tap back together, the hot water flowed fine so that seemed to cure it. I'm not sure what I did but it worked.

thanks for the help,

DIYnot Local

Staff member

If you need to find a tradesperson to get your job done, please try our local search below, or if you are doing it yourself you can find suppliers local to you.

Select the supplier or trade you require, enter your location to begin your search.

Are you a trade or supplier? You can create your listing free at DIYnot Local