Glowworm 35F Fuelsaver not firing main burner

Joined
19 Aug 2008
Messages
9
Reaction score
0
Location
Cornwall
Country
United Kingdom
Hi

My grand mother has a Glowworm 35F fuelsaver. It's a very old system with motorised switchmaster, grundfos external pump etc. It's been fine but recently developed a fault.

The pilot is coming on when the system is requesting heat and then there is a constant spark from pilot as if it's trying to fire the main burner but it's not firing. I've had a very busy chap out to look at it who suggested we replace the PCB. I managed to find a replacement online and have fitted that but the boiler is showing the same behaviour.

I can hear the solenoids clicking away to open the valves etc and the pilot lights just won't fire.

All other components seem to be operating correctly.

Any thoughts (apart from throw it away and replace it :))

Thanks
Simon
 
Joined
26 Jun 2004
Messages
64,092
Reaction score
4,620
Location
London
Country
United Kingdom
Did you pay him for the diagnosis?

I expect he may have sensed not getting paid and told you the wrong part to stuff you!

You should expect to pay for a diagnosis and normally have the same engineer do the repair.

We are not allowed to give advice on gas/combustion issues here.

Tony
 
Sponsored Links
Joined
19 Aug 2008
Messages
9
Reaction score
0
Location
Cornwall
Country
United Kingdom
Hi Tony, yes, he's being paid hansomely!!

The reason for me putting the board in is he is very busy and couldn't return for a number of days and my 91yo grand mother is stressed without heat and hot water. She has no other means of getting hot water as there is no emersion heater. He suggested I fit it as it doesn't have anything to do with the gas side of things.
 
Sponsored Links
Joined
19 Aug 2008
Messages
9
Reaction score
0
Location
Cornwall
Country
United Kingdom
Thanks Dan, somewhat more constructive. Just spoken to my man again who's going to come and clean up pilot and injector before we throw it on the scrap heap!
 
Top