Glowworm Ultracom 30CXi central heating doesn't turn on

7 Mar 2008
Reaction score
United Kingdom

I have a glowworm ultracom 30cxi

I haven't put my central heating on for sometime for obvious reasons, tried yesterday and nothing happened, I tried turning combi off and on again and still nothing, no sound, nothing, the hot water works fine though.
Anyone got any ideas? Or should I call british gas :)

Thanks for any help guys, :D
Sponsored Links
What controls have you got for the heating? Make sure the boiler is in heating mode. Press the mode button until both radiator and hot water symbols are visible. How old is the boiler? its probably still under guarantee. In any case its unlikley to be a fault with boiler, just controls.
might sound stupid, but is the room stat turned up.would also go with mickyg on the mode setup.the ultra cxi display timer is a pain in the ass.
Hi guys thanks for reply?

I'm doing this by memory as haven't been to my house in a couple days so bare with me.

MickyG: not sure if this helps the controls for boiler are like in this pic :

with a timer setting where the circle is, also have a control above combi with 2 buttons that have green lights (is that the mode buttons you're talking about?) and a thermo/temp control downstairs in hallway (which is turned right up to 27-28 degrees)

boiler is maybe 3 years old, just been serviced.

Holty: yes the room temp is up near to 30 degrees, you think turn this down? i'll check the mode display too, but it was working fine couple months ago, how come now its gone funny?

Thanks again :D
Sponsored Links
Hopefully it would have been tested when it was serviced?

It does rather sound as if you may not have selected the right settings on the boiler.

There is also a very small possibility that the room stat has failed.

If this is your house where you live you seem rather unfamiliar with the control settings.

Hi Agile,

It was working fine after service, that was about 2 months ago, haven't used central heating for a while though, then nothing.

OK, i'll check this later,

The room stat, is that the temp control I have in hallway?

yeh i'm renovating it so dont sleep there, just there for the work getting done/DIY etc
Room stat in hall.

Usually click when turned from low to high !

Your original post is incorrect! the boiler in the picture is the older CXi not an Ultracom. So my advice and Holtys should be partially disregarded.
Don't worry about the display now, there is no buttons for you to press, only to make sure that the heating dial is turned up, the timer control is on and the room stat is up. If it still fails to come on the you should get someone out.

WilfredoLimb - I have had the exact same problem with the same model boiler. I've tried replacing the room stat - still the same.

Did you get yours resolved?
Hi Guys,

Thanks for the help it was a control problem so nothing serious,

Gazzdaspazz; Think mine was a more simple problem to yours. You probably have tried this but have you tried the controls with the timer setting? I pressed the button with the pic of a 'hand' on it which I believe is the manual overide? And it worked, let me know how you get on

Thanks - I have tried the manual override but not in the past couple of days. Will give it a try but I've been through the timer settings and tried about every possibility on the timer. It looks like something simple but I've already had an engineer take a quick look and even he couldn't work it out. He's coming back again Monday.

DIYnot Local

Staff member

If you need to find a tradesperson to get your job done, please try our local search below, or if you are doing it yourself you can find suppliers local to you.

Select the supplier or trade you require, enter your location to begin your search.

Are you a trade or supplier? You can create your listing free at DIYnot Local

Sponsored Links