hotpoint aqaurius wf340 problem

11 Sep 2008
Reaction score
United Kingdom
can anyone help, i have a hotpoint aquarius wf340 and when i swith it on it starts to fill then the on/off light and rinse hold button which is the 3rd button down flash like mad and the machine starts to empty, it wont turn off and i have to unplug it to make it stop ???????????????
Sponsored Links
error code fo2 try and push the connecters on pcb .it it still does it it needs a pcb and eprom cost about 100 quid there is a company on the web that does recon boards for about 25 quid
thanks for the help, had one connector that was hanging off pushed it back on but still the same so guess it's gonna have to be a new pcb, any advice on where to get one would be gratefully received....
did you unplug mc ,not turn it off , for 2 mins after you found the connections loose , if it still not working google emw electronics ,based in nottingham they sell recon boards and are very cheap ,if theres no fault with your board they only charge a fiver ,i use these all the time and are very good :LOL:
Sponsored Links
Hi, new to the forum any help most welcome, i have the same problem with the on/off flashing rapidly and the rinse hold flashing slower were is the offending pcb located.
at the back, remove white cover its tucked in the corner .

DIYnot Local

Staff member

If you need to find a tradesperson to get your job done, please try our local search below, or if you are doing it yourself you can find suppliers local to you.

Select the supplier or trade you require, enter your location to begin your search.

Are you a trade or supplier? You can create your listing free at DIYnot Local