Hotpoint BWM129 stuck in the wash cycle

4 Jan 2012
Reaction score
United Kingdom
I have a Hotpoint BWM129 and it seems to be stuck in the wash cycle.

The programme is going on for hours and when it is stopped the washing is wet so I have to do a separate spin programme, which works fine when I set it manually.

Separately conditioner doesn't appear to be entering the machine and there is a drip from the pull-out drawer where we put washing powder/conditioner.

The machine is two years old and we have performed a maintenance wash (in which the cycle did complete!!) and tried to reset the software by leaving it unplugged all night.

Any ideas/help would be welcome!
Sponsored Links
thanks mate. Oddly, it isn't pulling through conditioner from the drawer (though it is getting soap powder) - same issue do you think?

Looks like a hard decision - fix or get new machine... :(
Thats correct wash only , once heater is fixed it will got to rinse , Heater is 20 quid and ten min job.
Sponsored Links
Yep that's the one. Little tip for you. Before you remove heater boil the kettle and tip it into the drum tip mc back and leave for 10 mins. The hot water will soften the rubber round the heater and will be easy to pull out. Don't forget to pump the water out before removing heater.
I have exactly the same problem. Can you tell me if this sorted out the problem for you?
I have come across this thread as I am trying to figure out how to replace the heater element on a BWM129 as I can't work out how the front panel comes off (doesn't seem like it does!)

rocks1, do you know how you access the heater element? Could you briefly describe to me how/where? Much appreciated.

Heater is at the back. Remove the big oval bit at the back. Heater is down at the bottom of the drum. Got 3 wires on it and poss two thin wires as well. Undo the nut in the middle and give it a good tug.
Brilliant. Thanks!

Now I've got the back off, it looks as though the heater element, and possibly the thermostat, are fairly new. Could it be that they aren't the problem after all? Any idea what else could be causing the machine not to heat the water?
Have you tested the heater first , should be 25 ish ohms. Or have continuity.
Tested the heater element this morning, it is showing continuity and a resistance.

I'm thinking maybe its the heater relay board? Any ideas about sourcing/replacing this?

What is the problem with the mc. What's is not doing any lights flashing,
When put on a programme requiring heating the water (eg 30 or 40 deg wash), one of two things happen: either it tries to fill a couple of times, then pumps out, flashing the bottom three LEDs + door lock LED.

Or, it starts and just lazily turns the drum for hours on end and needs to be forcibly moved to rinse/pump out to finish the wash.

When the temp selector is set to Cold, it just completes the programme normally (but with cold water, of course).

Thanks for your help rocks1, it's really appreciated :).

DIYnot Local

Staff member

If you need to find a tradesperson to get your job done, please try our local search below, or if you are doing it yourself you can find suppliers local to you.

Select the supplier or trade you require, enter your location to begin your search.

Are you a trade or supplier? You can create your listing free at DIYnot Local

Sponsored Links