Hotpoint washer WMA35P problem - possibly tacho?

30 Sep 2010
Reaction score
United Kingdom
Recently done some repairs on my Hotpoint WMA35P.

The machine stopped working after a few very noisy washes. On inspection, the drum bearings had rusted and shattered. I have replaced them and also put in a new heater element.

The repairs seem OK, but the machine will still not run properly. I did a component test which has indicated a problem with the motor.

During manual component test of motor (which should initiate slow tumble) there is a regular repeating click from somewhere on the PCB but no action from the motor.

I've had a look at the motor - the brushes and armature both seem OK. I am wondering if the tacho is the problem. Is it possible this could have been damaged as a result of the corroded bearings? The belt was off at the point of total breakdown.

Interested to hear any suggestions for (a) checking whether the tacho is faulty (b) possible alternative problems (c) whether the tacho can be repaired or where to get a replacement.

Thanks for reading.
Sponsored Links
If the tacho coil is open the speed sensing circuit won't see any reference voltage & the machine would have a tendency to run seriously overspeed. All you can do to check the tacho is measure the resistance & check that the shaft magnet is in place (maybe you could get a couple of volts out of it if you give it a good spin by hand). But I doubt very much if the tacho is at the root of your problem. It sounds more like the motor or pcb. did you perform these component tests?
Hi Zipper

Thanks - so probably not the tacho then. did you perform these component tests?

I bought a DIY/service manual which tells you how to initiate the auto component test and has a list of LED combinations and what errors they indicate. I ran it after replacing the bearings and it indicated problem with "motor, control module or associated wiring". I have also run the manual/individual component test routine for motor only and, as I said above, the test started and there was a regular, repeated clicking sound from a component on the PCB but no action from the motor.
Ok...good for you :D
I doubt if the tacho is actually defective. Take a look at the pcb for damaged components/tracks & check for a broken wires/bad plug connection in the motor circuit. Maybe you could remove the motor & ask your local domestic appliance workshop if they can bench test it for you? If you can identify which motor type your machine has I can run up it's values & you can check it with a multimeter.
Sponsored Links
The motor is now showing some activity. When put on a short wash cycle, it seems to be doing slow tumble as it should but it's terminating the program before the part where it should start doing a full spin.

The individual/manual component test will run the motor test (slow tumble) reasonably happily, but seemed a bit glitchy regarding how many tumbles it would do before stopping.

The auto component test routine is still terminating with error - "motor, control module or associated wiring".

Zipper - the service manual I have has a guide for multimeter test of the motor - have tested it - seemed OK as far as I can tell, but thanks for offering. There are no obvious faults on the PCB - no disconnected wires or scorched components...
Faults on pcb's are not always visible. Could be a faulty relay/reversing relay, speed contol circuit, triac, or some other component. What you could do is send your pcb to these guys & get it tested. Or buy an exchange for around 40 pounds. If it doesn't cure your problem return it undamaged in 21 days & it'll only cost 9 pounds + postage. Worth thinking about :?:

DIYnot Local

Staff member

If you need to find a tradesperson to get your job done, please try our local search below, or if you are doing it yourself you can find suppliers local to you.

Select the supplier or trade you require, enter your location to begin your search.

Are you a trade or supplier? You can create your listing free at DIYnot Local