Hotpoint WDL540 PCB fault

Discussion in 'Appliances' started by Dclark82, 30 Nov 2021.

  1. Dclark82

    Dclark82

    Joined:
    10 Aug 2016
    Messages:
    3
    Thanks Received:
    0
    Country:
    United Kingdom
    Hi all,

    First time poster and have signed up as my Hotpoint washer/dryer is on the blink, literally. After a few minutes of running a cycle, all the lights at the front of the machine start flashing orange.

    Machine was purchased around 2011 with only the occassional hiccup. We had to stop using one wash setting as we noticed it was tripping the circuits on the house for some reason.

    I initially found this site via this thread, and took particular note of post #61 with the slight redesigned PCB. I've taken out the PCB and confirm mine looks the same. No major obvious issues with the board ie. no swelling of the capicitors etc, some places look more dirty than others (some fine black dust that easily brushes off).

    Where each connection plugs into the PCB, the metal 'brass' teeth to hold the plugs look a little scorched ie. what looks like some minor burn marks. Beyond this, I can't really see anything wrong. The plugs were tightly secure when I took them out so I don't think there was a connectivity issue.

    Anyone got any other idea's? I'm thinking of buying a new PCB but for the life of me cannot find what I'm looking for.

    Many thanks,
     
  2. Sponsored Links
  3. delmel

    delmel

    Joined:
    28 Nov 2004
    Messages:
    801
    Thanks Received:
    42
    Country:
    United Kingdom
    Elements failing will likely trip your electric, what programme was it that trips and at what point is it tripping. Have you checked water is getting hot
     
Loading...

Share This Page