1. Visiting from the US? Why not try DIYnot.US instead? Click here to continue to DIYnot.US.
    Dismiss Notice

Hygiene ae6bms:- oven and grill not working but fan does

Discussion in 'Appliances' started by adamjth, 6 Jun 2020.

  1. adamjth

    adamjth

    Joined:
    21 Apr 2013
    Messages:
    19
    Thanks Received:
    0
    Location:
    Berkshire
    Country:
    United Kingdom
    Hi,

    As per the title we have a Hygiene AE6bMS with both oven and grill not working but fan seemingly spins up when the cooker controls (function & thermostat) are operated. This model:-

    http://argos.scene7.com/is/content/Argos/4894865_R_D001pdf

    Initially I thought the cooker element had gone but the fact the grill doesn't work scuppers that one. All electrics operate ok includin hob ignition + clock - any ideas anyone please?

    thanks

    Adam
     
  2. Sponsored Links
  3. jj4091

    jj4091

    Joined:
    1 Dec 2006
    Messages:
    5,180
    Thanks Received:
    487
    Location:
    Cumbria
    Country:
    United Kingdom
    My guess would be that the elements share the same neutral line which has over. heated somewhere along the way. Look for a burnt wire or connector somewhere.
     
    • Thanks Thanks x 1
  4. JohnD

    JohnD

    Joined:
    15 Nov 2005
    Messages:
    74,999
    Thanks Received:
    4,349
    Location:
    Crossgates, Europe
    Country:
    Cook Islands
    It could be a high resistance connection at any point. Need not be on the neutral. Perhaps more likely around the control panel where the switches are.

    The voltage is dropping under load.

    Have you got a multimeter?
     
    • Thanks Thanks x 1
  5. adamjth

    adamjth

    Joined:
    21 Apr 2013
    Messages:
    19
    Thanks Received:
    0
    Location:
    Berkshire
    Country:
    United Kingdom
    I do @JohnD have a multimeter and can use a soldiering iron but would say my knowledge is limited. isolate the power of course first...
     
  6. jj4091

    jj4091

    Joined:
    1 Dec 2006
    Messages:
    5,180
    Thanks Received:
    487
    Location:
    Cumbria
    Country:
    United Kingdom
    I'm still guessing obviously, but I would have thought it was something both elements had in common rather than a control problem for neither of them to work but the fan to be ok. It is where I would look first anyway.
     
  7. JohnD

    JohnD

    Joined:
    15 Nov 2005
    Messages:
    74,999
    Thanks Received:
    4,349
    Location:
    Crossgates, Europe
    Country:
    Cook Islands
    I was thinking the power supply will be brought to the panel of knobs, and it might be a connection on that cable at fault
     
  8. assuhors

    assuhors

    Joined:
    13 Jun 2007
    Messages:
    528
    Thanks Received:
    75
    Location:
    Sussex
    Country:
    United Kingdom
    Have a really close look at the oven function selector switch for melted contacts.
     
  9. DIYnot Local

    DIYnot Local

    Joined:
    3 Sep 2019
    Country:
    United Kingdom

    If you need to find a tradesperson to get your job done, please try our local search below, or if you are doing it yourself you can find suppliers local to you.

    Select the supplier or trade you require, enter your location to begin your search.


    Are you a trade or supplier? You can create your listing free at DIYnot Local

     
  10. Sponsored Links
Loading...

Share This Page