Indesit idl530 problem

Joined
6 Feb 2014
Messages
3
Reaction score
0
Location
Devon
Country
United Kingdom
Hi, I have an indesit idl530 dishwasher that was working perfectly well until we renovated the kitchen.
I reinstalled the dishwasher in a different location but continued to use the same fill connector and discharge point but on first use the first and third leds were flashing, indicating a discharge blockage and yes found the pipe was crimped preventing discharge but having resolved this problem it now has the second and fourth led flashing indicating a heating problem, I have checked all internal connections and checked the element at 27 ohms.
I contacted the indesit helpdesk who told me to turn off the machine for five minutes then retry, this proved futile, is there a reset procedure to follow after errors?

I would really appreciate any help.
 
Joined
30 Apr 2008
Messages
6,137
Reaction score
1,041
Country
United Kingdom
Does the lights flash straight away or half way during the wash
 
Sponsored Links
Joined
6 Feb 2014
Messages
3
Reaction score
0
Location
Devon
Country
United Kingdom
Hi, the leds come on after about 30 seconds from switch on as the water is input.
 
Joined
30 Apr 2008
Messages
6,137
Reaction score
1,041
Country
United Kingdom
Heater relay has gone open curcuit on the pcb.
 
Sponsored Links
Joined
6 Feb 2014
Messages
3
Reaction score
0
Location
Devon
Country
United Kingdom
Thanks for that Rocks, replaced relay still same problem, now decided to remove pumps etc and sell on ebay, buying a new dishwasher.
 
Top