One radiator not working

Joined
18 May 2020
Messages
4
Reaction score
0
Country
United Kingdom
Hi all, hope you can help.

I have one radiator that won't heat up. After watching a few YouTube vids I've already tried a few things.

I've booked the radiator though only a little air came out. I've checked the TRV pin which is ok.

I'm now looking at the Lockshield valve which I can't get to turn. All the videos I've seen show a valve that looks like the head of a flathead screwdriver. The one I have is a tube with two of the outer edges flattened off.

Is there a specific tool/key I need for this?
 

Attachments

  • IMG_20200518_153544.jpg
    IMG_20200518_153544.jpg
    90 KB · Views: 146
  • IMG_20200518_153532.jpg
    IMG_20200518_153532.jpg
    105.2 KB · Views: 142
Sponsored Links
Joined
8 May 2017
Messages
6,649
Reaction score
1,415
Country
United Kingdom
Spanner across the two flats ,turn anti clockwise to open the valve. If it will not turn , it may be fully open.
 
Joined
21 Sep 2011
Messages
4,542
Reaction score
1,042
Country
United Kingdom
Adjustable spanner across the flats (y) or if you are a plumber who should know better pipe grips:whistle:!
 
Joined
18 May 2020
Messages
4
Reaction score
0
Country
United Kingdom
Ha, I'm not a plumber.

Got it open, a bit wd40 did the trick of loosening it up.

Didn't help though unfortunately.

The pipes both leading in and out of the radiator remain cold even when the heating is on though I can hear something happening... Little clicks and a slight hum... Any ideas?
 
Joined
8 May 2017
Messages
6,649
Reaction score
1,415
Country
United Kingdom
Has the rad ever worked ?
Turn all other rads off at their TRV ,and see if this one heats up.
 
Sponsored Links
Sponsored Links
Top