1. Visiting from the US? Why not try DIYnot.US instead? Click here to continue to DIYnot.US.
    Dismiss Notice

Potterton suprema 60 not firing up

Discussion in 'Plumbing and Central Heating' started by Bibs, 5 Nov 2018.

  1. Bibs

    Bibs

    Joined:
    12 Jan 2013
    Messages:
    3
    Thanks Received:
    0
    Location:
    Hampshire
    Country:
    United Kingdom
    Hi,

    Hope I can get some advice with my boiler that is playing up.

    The boiler has the flashing red light, goes through ignition sequence when reset is pressed, but doesn't fire.

    I have seen some other similar threads, however something I tried today doesn't make sense to me.

    After taking the front off I noticed the electrode lead was falling apart at the electrode end and didn't have continuity from one end to the other, so I picked up a replacement from the local parts shop.

    Just fitted this and now when pressing reset it doesn't go through ignition sequence, green light comes on and goes straight out?

    I gave the GC number to the parts shop, so presume the lead is right (although it is a lot thinner than the original)

    When I fit the old lead it goes through ignition sequence on reset, but still doesn't fire.

    After just getting on some steps I can see that there is a spark with the old lead fitted through the viewing glass.

    Confused...
     
  2. Dan Robinson

    Dan Robinson

    Joined:
    1 Jul 2007
    Messages:
    56,034
    Thanks Received:
    9,419
    Location:
    Hertfordshire & London
    Country:
    United Kingdom
    Call a professional.
     
  3. Sponsored Links
  4. Bibs

    Bibs

    Joined:
    12 Jan 2013
    Messages:
    3
    Thanks Received:
    0
    Location:
    Hampshire
    Country:
    United Kingdom
    Gee thanks, the irony of posting on a DIY forum
     
  5. Dan Robinson

    Dan Robinson

    Joined:
    1 Jul 2007
    Messages:
    56,034
    Thanks Received:
    9,419
    Location:
    Hertfordshire & London
    Country:
    United Kingdom
    The irony of registering on a diy forum at not reading the rules nor the dirty great sticky on the top of the thread listings. :rolleyes:
     
  6. DIYnot Local

    DIYnot Local

    Joined:
    3 Sep 2019
    Country:
    United Kingdom

    If you need to find a tradesperson to get your job done, please try our local search below, or if you are doing it yourself you can find suppliers local to you.

    Select the supplier or trade you require, enter your location to begin your search.


    Are you a trade or supplier? You can create your listing free at DIYnot Local

     
  7. Sponsored Links
Loading...

Share This Page