Problem pairing a Salus iT500BM with existing RXBC605 - help please!

Joined
10 Oct 2020
Messages
3
Reaction score
1
Country
United Kingdom
Hi all, got a bit of an odd one and not sure the best way to sort it.

Boiler is a Baxi Duotec combi 33 which has been fine since we got it, 'stat setup was a Salus rxbc605 receiver on the boiler, with a battery powered RTX501RF(TX) 868mhz thermostat - nothing fancy but did the job OK.

The 'stat box has seen a few battle scars including a puppy chewing it, and finally started to give up the ghost last week.

Looking online the options were to replace it like for like, get a slightly better one that had phone controls etc on it, or look at a whole new setup.

Not wanting to get an engineer etc involved for wiring up I opted for a Salus iT500BM thermostat which is compatible with the boiler receiver. Got it, set it up, followed the pairing instructions and... nothing. 'Stat and receiver just fail to see each other and the pairing times out.

Tried turning boiler off for ten mins and restarting, likewise with the thermostat but still nothing.

Procedure is meant to be hold down 'sync' button on receiver until the orange light flashes every second, then enter the pairing screen on the 'stat - you then get a 10 minute countdown on screen and the two are meant to sync up, but it just completes without anything happening bu the looks of it.

Annoyingly if I pop batteries back in the old one it still talks to the boiler, so it just seems to be the pairing that's not working.

Anyone seen similar? Or should I send the new one back and start again with something else?

There are no jumper switches etc on this receiver either so it's all meant to be automatic - the old thermostat however does have jumpers so the fallback option might be to send the iT500 back and just get another RTX

Any advice appreciated!

Cheers,
Dan
 
Sponsored Links
Joined
10 Oct 2020
Messages
3
Reaction score
1
Country
United Kingdom
Still no luck - returning thermostat tomorrow and replacing with a like for like RTX501 (n)
 
Joined
10 Oct 2020
Messages
3
Reaction score
1
Country
United Kingdom
Just to put this to bed in case anyone finds this via google with the same issue - heard back from Sales support and apparently older models of the RXBC605 won't work with the IT500BM as it needs the newer firmware - unhelpfully though the model number stays the same regardless of the firmware version!

Took a punt and ordered a 'new' RXBC605 and noticed it had a "V3" sticker on the back - replaced it on the boiler and the thermostat paired up straight away.
 
  • Thanks
Reactions: CBW
Sponsored Links
Top