Punto - Dodgy heating (And rear wiper advice pls)

Joined
13 Feb 2006
Messages
93
Reaction score
0
Location
Suffolk
Country
United Kingdom
Hi there,

I sent the wifes Punto into a garage because water was leaking from somewhere, the garage identified the fault as a damaged water pump. Fair enough!

Having identified the fault I also asked them to replace the pump and do a full service, of which they did. However, since coming back from the service, the heating has been a bit hit and miss. (Mainly miss) I have found the little valve thing at the back of the engine which I opened up, a lot of air came out and then eventually water. Great I thought! I checked the tank and topped up as necessary. Even after doing this, I am still releasing air every now and again, also, the heating only seems to come out (when the heater is actually working) when the engine is revving! This isn't right is it?

Any advice with this will be greatly appreciated!

Also, I have just found out that the rear wiper is not working. When you turn the stick to operate it, you hear a clicking noise from the rear of the car but the wiper doesn't move! Is this a new wiper motor?

Thank you.

Cameron
 
Sponsored Links
Joined
16 Jan 2006
Messages
2,994
Reaction score
293
Location
Newport, S Wales.
Country
United Kingdom
you probably still have air in the system,some cars are hard work to get rid of the air locks,keep an eye on the water level and try bleeding again
as for the wiper you need to pop the panel off the boot and have a look to see if everything is still attatched
 
Joined
13 Feb 2006
Messages
93
Reaction score
0
Location
Suffolk
Country
United Kingdom
Hi,

topped up the water last weekend and all was fine until Friday. Basically the missus was driving home from work (9 miles), got stuck in traffic and the car overheated etc. Just don't understand, looking at he car on the drive and there are no leaks what so ever! I have worked out that I have put 5-6 pints of water in the thing since it's services and still is somehow runs dry!

As for the rear wiper, picked up a motor for peanuts and all is now working a treat.
 
Joined
13 Feb 2006
Messages
93
Reaction score
0
Location
Suffolk
Country
United Kingdom
Hi there,

thanks for the replies, basically I have just got rid of the car. Got a decent price for it on eBay.

Firstly I took it back to the garage and demonstrated the issue we've been having with it since the service and fair play, the mechanic said that there is certainly something not right. He had it for another day and sorted out what the issue was. I never bothered asking as to be honest, I was fed up to the back teeth with it.

Later that day, the in laws offered up their car for a very good price as they have just ordered a new one. So onto eBay went the Punto!

Thank you again!
 
Sponsored Links
Top