Pyronix Enforcer Siren Fault ( Now Silent )

5 Jan 2021
Reaction score
United Kingdom
Hi Folks,

Had the Pyronix Enforcer Wireless WiFi system installed for a couple of years now, was getting the low battery for siren alert so just got my brother to come up and he has just replaced the batteries for me on the Wall Siren, when opening the casing the tamper alarm went off as expected so that’s fine. Entered engineers menu and reset it etc. No problem

Once he installed the batteries I thought of perform a test , alarm armed fine and went off again fine but now the Siren isn’t making any sound! The lights are flashing , the internal alarm is sounding and I’m getting the notifications on my phone

No Faults on the control panel either , went into the engineers menu to test the siren again. Same result , lights flash but no actual noise coming from the Siren

tested the tamper trigger and that works fine, he had to rush away there

so I thought I’d ask this question incase he has missed something when connecting the 2 replacement batteries? As everything else is working perfectly now bar the actual noise from the Siren!

thanks in advance
Sponsored Links
Is it a MK 2 Unit ? Two flat batteries and NO ....input for power supply ? Would need picture of bellbox pcb with the internal cover open ....if so you need to replace it ...
Not really sure if you understand my query? Or maybe I’m picking you up wrong

alarm system in general is fine , just the last week I’ve been getting the low battery warning for the outside siren

so I bought 2 new batteries and my brother came up today to replace them

The tamper alarm went off when he opened the bell box as it’s meant to, he then replaced the batteries and I reset all the warnings etc

however now the actual noise of the Siren won’t sound, it will activate as normal. the light will flash and I will get the notifications on my app but for some reason there is No sound coming from the Bell Box now

tried it half a dozen times but still no sound

so I’m just wondering if he has missed something or perhaps been too heavy handed when installing the new batteries?

Just incase anyone has encountered the same issue after replacing the batteries

unfortunately I am disabled and unable to get up to the bell box to send any pics

hope this helps

I do ! So in layman’s terms .....since you have replaced the bellbox batteries....the siren doesn’t ring when you activate the alarm , the strobe works and the leds but no siren ....
Sponsored Links

yeah layman’s works perfectly for me lol

Yes that’s exactly it, he struggled to get the casing opened and used a bit of force to do so

Is there an easy way to pry it open?

I was thinking he maybe dislodged a connection to actual siren or has missed something?

I can get him back to look at again during the week

so any instructions or pictures that you or anyone could provide would be fantastic thanks

I did the original installer first but he’s very unreliable
DB0AA831-7A26-42CF-8142-0D90AC6255B1.jpeg Mk3 with power input terminals
Thanks for the pics, when you say with and without power input terminals does that mean one is wired up the mains? The one I have is not

apologies if that isn’t what it means

Where is the connector for actual siren in the casing?

does the actual casing open easy? He had to pry it open from the side using a screw driver!

your patience and help is appreciated thanks

DIYnot Local

Staff member

If you need to find a tradesperson to get your job done, please try our local search below, or if you are doing it yourself you can find suppliers local to you.

Select the supplier or trade you require, enter your location to begin your search.

Are you a trade or supplier? You can create your listing free at DIYnot Local

Sponsored Links