1. Visiting from the US? Why not try DIYnot.US instead? Click here to continue to DIYnot.US.
    Dismiss Notice

RealTEK USB wireless adapter connects and then drops offline

Discussion in 'Hardware' started by timbook, 22 Apr 2020.

  1. timbook

    timbook

    Joined:
    8 Feb 2015
    Messages:
    134
    Thanks Received:
    5
    Country:
    United Kingdom
    I think this is a hardware issue.
    I have a generic desktop tower PC here. It's a little bit old but the specs are enough to run windows 10. I installed windows 10 Home and Activated it. All drivers were fine. There is no wireless adapter in the tower and so I connected a realtek RLT8188CU USB2.0 wireless adapter to it. It is 802.11n type.
    It installed immediately and perfectly and I connected to the wifi here at home.
    After about 2 minutes it lost the internet connection. It stays connected to the router but won't go online. I found a workaround which is to go into network settings and turn the Wifi off and back on again and then it usually stays connected until my next restart where it happens all over again.
    I have tried uninstalling and reinstalling, trying to update the drivers but it always says I have the best one installed. I've tried resetting all networks, but it leads to the same problem once I connect to the wifi again. In the events section of device manager it does say that this device needs more installation, but I just don't know what to do or even what that means.
    Windows has done all updates up until today.
    I don't use external antivirus or firewall but rather keep the windows defender stuff instead. Troubleshooting doesn't help either.
    If turning my Wifi off and on again in network settings fixes the issue then that maybe tells us clues as to why it won't stay connected until I do that? Any help appreciated.
     
  2. Sponsored Links
  3. rsgaz

    rsgaz

    Joined:
    28 Jul 2014
    Messages:
    1,791
    Thanks Received:
    491
    Country:
    United Kingdom
    Could be the USB port going to sleep, Google "disable USB selective suspend" and give that a try. This is usually for laptops, but worth a try on your tower.
     
    • Thanks Thanks x 1
    • Like Like x 1
  4. timbook

    timbook

    Joined:
    8 Feb 2015
    Messages:
    134
    Thanks Received:
    5
    Country:
    United Kingdom
    That didn't fix it but it was good to learn something new. The work around doesn't take long so i will have to stick with that.
     
  5. Hyper88

    Hyper88

    Joined:
    15 Apr 2010
    Messages:
    60
    Thanks Received:
    1
    Country:
    United Kingdom
    It is probably the quality of your device, even if it has a Realtek chip. I read a number of reviews and many of these type of devices have poor reviews.

    Gibabyte was on the best branded (I wanted wifi and Bluetooth).
     
  6. fluorescence

    fluorescence

    Joined:
    15 Jun 2018
    Messages:
    185
    Thanks Received:
    22
    Country:
    United Kingdom
  7. rossj81

    rossj81

    Joined:
    13 Nov 2019
    Messages:
    40
    Thanks Received:
    13
    Location:
    Warwickshire
    Country:
    United Kingdom
    I don't think it's a hardware issue, as I have a Dell laptop with integrated wi-fi and experience the same problem. Mine definitely isn't hardware because the same device worked perfectly on Win7 before I "upgraded".

    That said, buying a different device like fluorescence suggested would obviously use different drivers and might sidestep the problem.
     
  8. Astra99

    Astra99

    Joined:
    1 Feb 2011
    Messages:
    875
    Thanks Received:
    142
    Location:
    Gloucestershire
    Country:
    United Kingdom
    Some of these devices can be finnicky about the driver being used. Go to the manufacturer's website and download the latest driver for Windows 10. Uninstall the "old" driver, removing all files, and then install the new driver.
     
  9. Sponsored Links
Loading...

Share This Page