Reinstalled Windows 7 - now no WiFi

Joined
8 Mar 2009
Messages
23
Reaction score
1
Country
United Kingdom
Hope you can help please.

Have done a full reinstall of Windows 7 Professional on my Dell Inspiron laptop. I can get internet from my router ok but only with a cable - no Wi Fi seems to be available. (I realise now I've installed the 32 bit version on a 64 bit laptop, so I don't know if this is the problem?) Is there a simple solution to this please to get Wi Fi back? Thanks
 
Sponsored Links
Joined
8 Mar 2009
Messages
23
Reaction score
1
Country
United Kingdom
Thanks. Can you tell me how to do that please? Where will I access it?
 
Joined
8 Feb 2015
Messages
182
Reaction score
8
Country
United Kingdom
I know for a fact that some 32 bit machines blue screen out regularly when 64 bit OS is installed. That doesn't mean that it happens in the opposite direction of course but it is worth thinking about.
If there isn't a 32 bit driver for your wireless adapter, just try the 64 bit one anyway. It could well work
 
Joined
1 Feb 2011
Messages
916
Reaction score
197
Location
Gloucestershire
Country
United Kingdom
99 times out of 100 the drivers which Windows installs are either out of date or the wrong driver entirely!

Go into Device Manager (right click on Computer go to Manage and then select Device Manager. In the list on the right hand side expand network adapters and look for the wireless adapter installed in your PC. It will probably have a yellow exclamation mark next to it. Alternatively, it may be listed with the yellow mark under Other Devices. Right click on the entry and go to Properties. Select Hardware IDs from the dropdown list. This will probably start off PCI\VEN_. Do a copy & paste of the PCI\VEN number into a Google search engine. This will hopefully give you the manufacturer and model of your Wireless device, so you can go to the manufacturer's website and download the 32-bit driver.
 
Sponsored Links
Top