Servis Washer Easi Logic 1600 Fault

Discussion in 'Appliances' started by JamM, 16 Oct 2014.

  1. JamM

    JamM

    Joined:
    13 Sep 2014
    Messages:
    4
    Thanks Received:
    0
    Location:
    Nottinghamshire
    Country:
    United Kingdom
    Hello can anyone give me some advice on this fault please. On a 40/50oC cycle the washer fills with water (not completely) water heats up but drum doesn't revolve, pump removes water, then it doesn't refill with water to rinse, doesn't spin, programme ends & switches off after a few minutes on a wash cycle which normally would take 1hour 40 mins. Somebody suggested it may be the PCB which is expensive. Can anyone help me please? Thank you
     
  2. Sponsored Links
  3. jj4091

    jj4091

    Joined:
    1 Dec 2006
    Messages:
    5,203
    Thanks Received:
    490
    Location:
    Cumbria
    Country:
    United Kingdom
    Drive belt & motor brushes would be the first things I would look at.
     
  4. JamM

    JamM

    Joined:
    13 Sep 2014
    Messages:
    4
    Thanks Received:
    0
    Location:
    Nottinghamshire
    Country:
    United Kingdom
    Thanks for your quick reply, however when use spin mode on program switch it will spin normally, which indicated that the pcb could be faulty as its not cycling through the selected program, but I will check this a let you know thanks.
     
  5. DIYnot Local

    DIYnot Local

    Joined:
    3 Sep 2019
    Country:
    United Kingdom

    If you need to find a tradesperson to get your job done, please try our local search below, or if you are doing it yourself you can find suppliers local to you.

    Select the supplier or trade you require, enter your location to begin your search.


    Are you a trade or supplier? You can create your listing free at DIYnot Local

     
Loading...

Share This Page