1. Visiting from the US? Why not try DIYnot.US instead? Click here to continue to DIYnot.US.
    Dismiss Notice

Shower help - won't run cold

Discussion in 'Plumbing and Central Heating' started by jono_h, 5 Jul 2014.

  1. jono_h

    jono_h

    Joined:
    19 May 2006
    Messages:
    295
    Thanks Received:
    24
    Country:
    United Kingdom
    I'm hoping I can get some advice and pointers for a shower problem - basically I can't get it to run cold, it's either hot or really hot!

    It's a wickes Origin LL thermostatic shower (which I believe is a rebadged Bristan Chill or similar), fed via a Salamander RSP 100 pump, from a balanced supply.

    I've tried setting the temperature as per the instructions, but even with the handle set as far cold as it will go it makes no difference. I've checked the inlet filters which are clear. I've swapped the pump with a known good unit with the same issue. I've disconnected the connections to the shower and run the pump into a bucket, which gives a good flow. So now I'm a little stuck.

    Is there anything else I can check, to determine the issue? Could it be a faulty thermostatic cartridge?

    Many thanks, Jon.
     
  2. Sponsored Links
  3. willsgas

    willsgas

    Joined:
    7 Sep 2011
    Messages:
    202
    Thanks Received:
    68
    Country:
    Italy
    is this a new valve, or has it suddenly stopped working?
     
  4. DIYnot Local

    DIYnot Local

    Joined:
    3 Sep 2019
    Country:
    United Kingdom

    If you need to find a tradesperson to get your job done, please try our local search below, or if you are doing it yourself you can find suppliers local to you.

    Select the supplier or trade you require, enter your location to begin your search.


    Are you a trade or supplier? You can create your listing free at DIYnot Local

     
Loading...

Share This Page