Smeg Dishwasher E1 Error After Power Cut

Joined
26 Oct 2017
Messages
4
Reaction score
0
Country
United Kingdom
Hi folks

My Smeg DI6012 dishwasher is throwing up an E1 error code after a recent power cut. There is no water inside the base (bone dry) and I have tried to reset by doing the "switch on, press program button 4 times etc" routine. But the reset procedure doesn't appear to work.

Does anyone have any other advice on how I can reset the dishwasher in another way? Or indeed any other advice?

Thanks so much in advance!

Lev
 
Sponsored Links
Thanks jj4091 - but I don't have a leak. There's no water in the tray at the base of the dishwasher. It's bone dry.

I suspect it's something to do with the powercut we had. Either that, or something else I'm not aware of.

Any ideas on how to reset the machine?

At the moment, whenever I switch it on it sounds like some pump is trying to pump water out - but there's nothing to pump.

Thanks!
 
Sponsored Links
its possible the drain pump relay is jammed causing it to stick on the drain function
 
Thanks Yardie, is there a way for me to try and un-jam it?
 
tapping the relay can sometimes free it but if its 'welded' on good then no. the machine will need to be on whilst doing this so be careful not to touch any of the connections.

you can test it yourself quite easily.

let me know the markings on the relay in question or a photo of the relays markings

probably better to have a photo of the top of the pcb and the bottom side of the pcb where the relay is. there is no need to remove the relay from the pcb. just be sure the machine is unplugged whilst doing this.
 
Last edited:
When you say 'relay', do you mean the little styrofoam float? I've tried tapping it and it moved up by about a couple of millimeters. But doesn't make a difference. Or did you mean something else?

I have attached a photo. Please let me know if that helps?

Thanks
 

Attachments

  • IMG_3112.JPG
    IMG_3112.JPG
    190.2 KB · Views: 613
that float is what operates the drain function microswitch, do you hear a click when you raise the float? and a click when you lower it?

the relay would be located on the mainboard, 240v voltages present so be careful.
 
the float does not look like it is centred under the white 'pan', is there a lever attached to the float, usually a blue, black or white lever (stick), pointing upwards.

the lever could be wedged between the float and the microswitch.

careful, the floats do easily break up especially if they have become brittle

sometimes there is not a lever but the float itself that makes contact directly with the microswitch

this would not have been caused by the power cut but worth checking first especially whilst your there
 
Last edited:

DIYnot Local

Staff member

If you need to find a tradesperson to get your job done, please try our local search below, or if you are doing it yourself you can find suppliers local to you.

Select the supplier or trade you require, enter your location to begin your search.


Are you a trade or supplier? You can create your listing free at DIYnot Local

 
Sponsored Links
Back
Top